summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTechnion <technion@lolware.net>2013-06-01 04:11:06 -0400
committerTechnion <technion@lolware.net>2013-06-01 04:11:06 -0400
commit99519f7089751e3bcce868d5c8c23c3e84ad0ecb (patch)
tree2d379e7ac4a1237e9c6f4c986d3ca9f7a1370fd6 /Makefile
parent71b24bc7e862693e5134ba774ffb0c4fed1e11f5 (diff)
Created the easy hash function
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 36951bb..30b04db 100644
--- a/Makefile
+++ b/Makefile
@@ -1,11 +1,11 @@
CC=gcc
-CFLAGS=-O2 -Wall
+CFLAGS=-O2 -Wall -g -std=gnu99
all: reference
-OBJS= crypto_scrypt-nosse.o sha256.o crypto_scrypt-hexconvert.o crypto-mcf.o modp_b64.o crypto-scrypt-saltgen.o crypto_scrypt-check.o
+OBJS= crypto_scrypt-nosse.o sha256.o crypto_scrypt-hexconvert.o crypto-mcf.o modp_b64.o crypto-scrypt-saltgen.o crypto_scrypt-check.o crypto_scrypt-hash.o
crypto-mcf.o: crypto-mcf.c
- gcc -Wall -std=gnu99 -c -o crypto-mcf.o crypto-mcf.c
+ gcc -g -Wall -std=gnu99 -c -o crypto-mcf.o crypto-mcf.c
library: $(OBJS)
ar rcs libscrypt.a $(OBJS)