summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorTechnion <technion@lolware.net>2014-04-15 03:59:34 +0000
committerTechnion <technion@lolware.net>2014-04-15 03:59:34 +0000
commiteeaf35fa036f487999d50f2b4141dc09b7862ff7 (patch)
tree359c7d0f0d3f27d796a19140e5c6c850bae268cf /Makefile
parented9199a3b65b787def6fb4a956a863a5bb8f88a7 (diff)
Implement constant-time comparison.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index fdc0347..a5af9ac 100644
--- a/Makefile
+++ b/Makefile
@@ -11,13 +11,13 @@ CFLAGS_EXTRA?=-Wl,-rpath=.
all: reference
-OBJS= crypto_scrypt-nosse.o sha256.o crypto_scrypt-hexconvert.o crypto-mcf.o b64.o crypto-scrypt-saltgen.o crypto_scrypt-check.o crypto_scrypt-hash.o
+OBJS= crypto_scrypt-nosse.o sha256.o crypto_scrypt-hexconvert.o crypto-mcf.o b64.o crypto-scrypt-saltgen.o crypto_scrypt-check.o crypto_scrypt-hash.o slowequals.o
libscrypt.so.0: $(OBJS)
$(CC) $(LDFLAGS) -shared -o libscrypt.so.0 $(OBJS) -lm -lc
ar rcs libscrypt.a $(OBJS)
-reference: libscrypt.so.0 main.o b64.o
+reference: libscrypt.so.0 main.o b64.o slowequals.o
ln -s -f libscrypt.so.0 libscrypt.so
$(CC) -Wall -o reference main.o b64.o $(CFLAGS_EXTRA) -L. -lscrypt