summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 466d08a..5319ea4 100644
--- a/Makefile
+++ b/Makefile
@@ -6,10 +6,10 @@ OBJS= crypto_scrypt-nosse.o sha256.o crypto_scrypt-hexconvert.o crypto-mcf.o mod
library: $(OBJS)
- gcc -shared -Wl,-soname,libscrypt.so -Wl,--version-script=libscrypt.version -o libscrypt.so -lc $(OBJS)
+ $(CC) -shared -Wl,-soname,libscrypt.so.0 -Wl,--version-script=libscrypt.version -o libscrypt.so -lc $(OBJS)
reference: library main.o
- gcc -Wall -o reference main.o -Wl,-rpath=. -L. -lm -lscrypt
+ $(CC) -Wall -o reference main.o -Wl,-rpath=. -L. -lm -lscrypt
clean:
rm -f *.o reference libscrypt.so