summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Cowgill <jcowgill@debian.org>2024-05-12 22:56:18 +0100
committerJames Cowgill <jcowgill@debian.org>2024-05-12 22:56:18 +0100
commit1be5471991b245ec21b9f4635b6674f2bfb03891 (patch)
tree2b5a691c265764ac6468fdc5618cb88b534d2567
parent7d78efb67434e124958ad03723765064167ced75 (diff)
Adjust build script to build documentation only once
Forwarded: no This patch removes the ALL option from the documentation build command so that it must be run manually with "make doc". This prevents the documentation being built twice (normal build + install phase). It also allows the documentation building to happen after the code building, which makes the logs much more readable in parallel builds. Forwarded: no Gbp-Pq: Name 02_build-doc-once.patch
-rw-r--r--doc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 7b3146d..c77d10d 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -46,7 +46,7 @@ configure_file(${DOXYGEN_INPUT_DIR}/doc/doxygen.css ${DOXYGEN_OUTPUT_DIR}/html/d
configure_file(${DOXYGEN_INPUT_DIR}/doc/searchOverrides.css ${DOXYGEN_OUTPUT_DIR}/html/searchOverrides.css COPYONLY)
# target setup
-add_custom_target(doc ALL
+add_custom_target(doc
COMMAND ${CMAKE_COMMAND} -E echo_append "Building API Documentation..."
COMMAND ${DOXYGEN_EXECUTABLE} ${DOXYGEN_CONFIGURED_INPUT}
COMMAND ${CMAKE_COMMAND} -E echo "Done."