summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Cowgill <jcowgill@debian.org>2016-08-09 15:32:44 +0000
committerJames Cowgill <jcowgill@debian.org>2016-08-09 15:32:44 +0000
commit26daf0a5a58e1169a08cc91697e5eb0a8f6b797d (patch)
tree7141ed64eac11de64fb9f7fb95d2cd4f06ce5a5e
parent1d14f95240143251983c93bf6900732d40689867 (diff)
Refresh patches
-rw-r--r--debian/patches/02_hurd.patch10
-rw-r--r--debian/patches/06_pkgconfig-freebsd.patch2
2 files changed, 6 insertions, 6 deletions
diff --git a/debian/patches/02_hurd.patch b/debian/patches/02_hurd.patch
index 1980a38..ce8c63d 100644
--- a/debian/patches/02_hurd.patch
+++ b/debian/patches/02_hurd.patch
@@ -8,17 +8,17 @@ Forwarded: no
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/cmake/Config.cmake
+++ b/cmake/Config.cmake
-@@ -31,6 +31,12 @@ elseif(${CMAKE_SYSTEM_NAME} MATCHES "Fre
+@@ -31,6 +31,12 @@ elseif(${CMAKE_SYSTEM_NAME} STREQUAL "Fr
set(SFML_OS_FREEBSD 1)
# don't use the OpenGL ES implementation on FreeBSD
set(OPENGL_ES 0)
-+elseif(${CMAKE_SYSTEM_NAME} MATCHES "GNU")
++elseif(${CMAKE_SYSTEM_NAME} STREQUAL "GNU")
+ # Hurd is almost identical to Linux except for joystick support, so pretend for the moment
+ set(SFML_OS_LINUX 1)
+ set(SFML_OS_HURD 1)
+ # don't use the OpenGL ES implementation on GNU Hurd
+ set(OPENGL_ES 0)
- elseif(${CMAKE_SYSTEM_NAME} MATCHES "Darwin")
+ elseif(${CMAKE_SYSTEM_NAME} STREQUAL "Darwin")
if(IOS)
set(SFML_OS_IOS 1)
--- a/include/SFML/Config.hpp
@@ -53,7 +53,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
set(PLATFORM_SRC
${PLATFORM_SRC}
${SRCROOT}/Unix/JoystickImpl.cpp
-@@ -211,7 +217,7 @@ if(SFML_OPENGL_ES AND SFML_OS_LINUX)
+@@ -218,7 +224,7 @@ if(SFML_OPENGL_ES AND SFML_OS_LINUX)
find_package(GLES REQUIRED)
include_directories(${EGL_INCLUDE_DIR} ${GLES_INCLUDE_DIR})
endif()
@@ -62,7 +62,7 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
find_package(UDev REQUIRED)
if(NOT UDEV_FOUND)
message(FATAL_ERROR "udev library not found")
-@@ -223,6 +229,8 @@ endif()
+@@ -230,6 +236,8 @@ endif()
# build the list of external libraries to link
if(SFML_OS_WINDOWS)
list(APPEND WINDOW_EXT_LIBS winmm gdi32)
diff --git a/debian/patches/06_pkgconfig-freebsd.patch b/debian/patches/06_pkgconfig-freebsd.patch
index 4427ee4..3f30b77 100644
--- a/debian/patches/06_pkgconfig-freebsd.patch
+++ b/debian/patches/06_pkgconfig-freebsd.patch
@@ -5,7 +5,7 @@ Forwarded: no
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -190,9 +190,6 @@ endif()
+@@ -199,9 +199,6 @@ endif()
if(SFML_OS_LINUX OR SFML_OS_FREEBSD)
set(PKGCONFIG_DIR lib${LIB_SUFFIX}/pkgconfig)