summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Thrasher <chrisjthrasher@gmail.com>2024-05-12 22:56:18 +0100
committerJames Cowgill <jcowgill@debian.org>2024-05-12 22:56:18 +0100
commitbf4787ae91ae9ec20604489f14ba1bfd8921d75c (patch)
treee9d5004c9963d763ee2f065a40e4571e3b346c08
parenta6d355c8a4836e11ca8b034e9f97242141ed6e1f (diff)
Don't automatically run tests after build
Origin: backport, https://github.com/SFML/SFML/commit/0b6254394275dfe7450772689134681bc7f36daf Bug: https://github.com/SFML/SFML/pull/2446 Bug-Debian: https://bugs.debian.org/1069298 Bug-Debian: https://bugs.debian.org/1069298 Gbp-Pq: Name 07_remove-runtests-all.patch
-rw-r--r--test/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 05b0223..8a40f63 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -41,11 +41,8 @@ if(SFML_BUILD_NETWORK)
sfml_add_test(test-sfml-network "${NETWORK_SRC}" sfml-network)
endif()
-# Automatically run the tests at the end of the build
-add_custom_target(runtests ALL
- DEPENDS test-sfml-system test-sfml-window test-sfml-graphics test-sfml-network
-)
-
+# Convenience for building and running tests in a single command
+add_custom_target(runtests DEPENDS test-sfml-system test-sfml-window test-sfml-graphics test-sfml-network test-sfml-audio)
add_custom_command(TARGET runtests
COMMENT "Run tests"
POST_BUILD COMMAND ctest ARGS --output-on-failure