summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorJames Cowgill <james410@cowgill.org.uk>2016-06-29 13:30:43 +0100
committerJames Cowgill <james410@cowgill.org.uk>2016-06-29 13:30:43 +0100
commita32672842cb30f6e0bffb4329b25db371b731ec9 (patch)
treeef6c369da352f5ba5265b4d4c0b3cfae8144a055 /debian
parent64c13cb48ab466b59a9835cd99f2f5c0f940bc23 (diff)
Add workaroud for GCC 5.3 bug
Diffstat (limited to 'debian')
-rw-r--r--debian/patches/07_gcc-5.3.patch25
-rw-r--r--debian/patches/series1
2 files changed, 26 insertions, 0 deletions
diff --git a/debian/patches/07_gcc-5.3.patch b/debian/patches/07_gcc-5.3.patch
new file mode 100644
index 0000000..23a5165
--- /dev/null
+++ b/debian/patches/07_gcc-5.3.patch
@@ -0,0 +1,25 @@
+Description: Workaround GCC 5.3 issues.
+ See:
+ https://github.com/nothings/stb/issues/280
+ https://bugs.launchpad.net/ubuntu/+source/gcc-5/+bug/1568899
+ https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65612
+ Compiler bug was fixed in 6.0
+Author: David Yip <yipdw@member.fsf.org>
+Origin: other, https://gitlab.peach-bun.com/pinion/SFML/commit/3383b4a472f0bd16a8161fb8760cd3e6333f1782
+
+--- a/src/SFML/Graphics/CMakeLists.txt
++++ b/src/SFML/Graphics/CMakeLists.txt
+@@ -148,6 +148,13 @@ add_definitions(-DSTBI_FAILURE_USERMSG)
+ # when gcc is used; otherwise saving PNGs may crash in stb_image_write
+ if(SFML_COMPILER_GCC)
+ set_source_files_properties(${SRCROOT}/ImageLoader.cpp PROPERTIES COMPILE_FLAGS -fno-strict-aliasing)
++
++endif()
++
++# see https://bugs.launchpad.net/ubuntu/+source/gcc-5/+bug/1568899
++if(SFML_COMPILER_GCC AND BUILD_SHARED_LIBS)
++ message(WARNING "Applying workaround for https://bugs.launchpad.net/ubuntu/+source/gcc-5/+bug/1568899")
++ list(APPEND GRAPHICS_EXT_LIBS "-lgcc_s -lgcc")
+ endif()
+
+ # define the sfml-graphics target
diff --git a/debian/patches/series b/debian/patches/series
index 06d8ed1..614c3d1 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@
04_remove-googleapi-css.patch
05_build-doc-once.patch
06_pkgconfig-freebsd.patch
+07_gcc-5.3.patch