summaryrefslogtreecommitdiff
path: root/examples/sockets/CMakeLists.txt
diff options
context:
space:
mode:
authorJames Cowgill <james410@cowgill.org.uk>2013-08-23 09:57:55 +0100
committerJames Cowgill <james410@cowgill.org.uk>2013-08-23 09:57:55 +0100
commit9a298ca833d9b6a3425bb30c2e52cf04e34aeb7c (patch)
treed46630a885bcea03bbea036b86c645dc6c55708d /examples/sockets/CMakeLists.txt
parent0969839d538a385254c6eced9648acc7299876cc (diff)
Imported Upstream version 2.1+dfsg
Diffstat (limited to 'examples/sockets/CMakeLists.txt')
-rw-r--r--examples/sockets/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/examples/sockets/CMakeLists.txt b/examples/sockets/CMakeLists.txt
new file mode 100644
index 0000000..04b3583
--- /dev/null
+++ b/examples/sockets/CMakeLists.txt
@@ -0,0 +1,12 @@
+
+set(SRCROOT ${PROJECT_SOURCE_DIR}/examples/sockets)
+
+# all source files
+set(SRC ${SRCROOT}/Sockets.cpp
+ ${SRCROOT}/TCP.cpp
+ ${SRCROOT}/UDP.cpp)
+
+# define the sockets target
+sfml_add_example(sockets
+ SOURCES ${SRC}
+ DEPENDS sfml-network sfml-system)