summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CMakeLists.txt2
-rw-r--r--changelog.txt51
-rw-r--r--include/SFML/Config.hpp2
-rw-r--r--include/SFML/Window/GlResource.hpp6
-rw-r--r--src/SFML/Window/GlContext.cpp6
-rw-r--r--src/SFML/Window/GlContext.hpp6
-rw-r--r--src/SFML/Window/GlResource.cpp7
7 files changed, 64 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe33ac2..77589da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,7 +45,7 @@ include(${CMAKE_CURRENT_SOURCE_DIR}/cmake/Config.cmake)
# setup version numbers
set(VERSION_MAJOR 2)
set(VERSION_MINOR 4)
-set(VERSION_PATCH 0)
+set(VERSION_PATCH 1)
# add the SFML header path
include_directories(${CMAKE_CURRENT_SOURCE_DIR}/include)
diff --git a/changelog.txt b/changelog.txt
index ff61a53..666e254 100644
--- a/changelog.txt
+++ b/changelog.txt
@@ -1,3 +1,51 @@
+SFML 2.4.1
+==========
+
+Also available on the website: http://www.sfml-dev.org/changelog.php#sfml-2.4.1
+
+General
+=======
+
+* [kFreeBSD] Define SFML_OS_FREEBSD when compiling for kFreeBSD (#1129)
+* [Window] Added some simple messaging when trying to build under Cygwin (#1153)
+
+
+Window
+======
+
+Bugfixes
+--------
+* Fixed stack overflow on GlContext creation with multiple threads (#989, #1002)
+* Adjusted mouse cursor grab documentation (#1133)
+* [iOS] Fixed orientation change not rescaling window size properly (#1049, #1050)
+* [Linux] Fixed fullscreen issue (#921, #1138)
+* [Linux] Switched from XCB back to Xlib for windowing (#1138)
+* [Linux] Fixed window icon not showing up on some distros (#1087, #1088)
+* [Linux] Fixed an issue where GNOME flags window unresponsive (#1089, #1138)
+* [Linux] Fixed leak of XVisualInfo objects during GlxContext creation (#1135)
+* [Linux] Fixed possible hang when setting visibility if external window sources (#1136)
+* [OS X] Fixed inconsistency between doc and impl on OS X for the grab feature (#1133, #1148, #1150)
+* [Windows] Fixed context memory leaks (#1143, #1002)
+
+
+Graphics
+========
+
+Bugfixes
+--------
+* Adjusted uniform error message (#1131)
+* Clarify documentation on Rect::contains function bounds (#1151)
+
+
+Network
+=======
+
+Bugfixes
+--------
+* Fixed a typo in comment for void unbind() (#1121)
+
+
+
SFML 2.4.0
==========
@@ -115,8 +163,6 @@ Bugfixes
-
-
SFML 2.3.2
==========
@@ -152,6 +198,7 @@ Bugfixes
* Secure function against random data return (#935, #942)
+
SFML 2.3.1
==========
diff --git a/include/SFML/Config.hpp b/include/SFML/Config.hpp
index 497ef67..9c68d84 100644
--- a/include/SFML/Config.hpp
+++ b/include/SFML/Config.hpp
@@ -31,7 +31,7 @@
////////////////////////////////////////////////////////////
#define SFML_VERSION_MAJOR 2
#define SFML_VERSION_MINOR 4
-#define SFML_VERSION_PATCH 0
+#define SFML_VERSION_PATCH 1
////////////////////////////////////////////////////////////
diff --git a/include/SFML/Window/GlResource.hpp b/include/SFML/Window/GlResource.hpp
index 876f177..627ec30 100644
--- a/include/SFML/Window/GlResource.hpp
+++ b/include/SFML/Window/GlResource.hpp
@@ -58,6 +58,12 @@ protected:
~GlResource();
////////////////////////////////////////////////////////////
+ /// \brief Empty function for ABI compatibility, use acquireTransientContext instead
+ ///
+ ////////////////////////////////////////////////////////////
+ static void ensureGlContext();
+
+ ////////////////////////////////////////////////////////////
/// \brief RAII helper class to temporarily lock an available context for use
///
////////////////////////////////////////////////////////////
diff --git a/src/SFML/Window/GlContext.cpp b/src/SFML/Window/GlContext.cpp
index 23cf483..8ae4b3a 100644
--- a/src/SFML/Window/GlContext.cpp
+++ b/src/SFML/Window/GlContext.cpp
@@ -231,12 +231,6 @@ void GlContext::globalCleanup()
////////////////////////////////////////////////////////////
-void GlContext::ensureContext()
-{
-}
-
-
-////////////////////////////////////////////////////////////
void GlContext::acquireTransientContext()
{
// If a capable context is already active on this thread
diff --git a/src/SFML/Window/GlContext.hpp b/src/SFML/Window/GlContext.hpp
index abcda4b..55b6c1f 100644
--- a/src/SFML/Window/GlContext.hpp
+++ b/src/SFML/Window/GlContext.hpp
@@ -73,12 +73,6 @@ public:
static void globalCleanup();
////////////////////////////////////////////////////////////
- /// \brief Empty function for ABI compatibility, use acquireTransientContext instead
- ///
- ////////////////////////////////////////////////////////////
- static void ensureContext();
-
- ////////////////////////////////////////////////////////////
/// \brief Acquires a context for short-term use on the current thread
///
////////////////////////////////////////////////////////////
diff --git a/src/SFML/Window/GlResource.cpp b/src/SFML/Window/GlResource.cpp
index a3cdddf..e9a9ecc 100644
--- a/src/SFML/Window/GlResource.cpp
+++ b/src/SFML/Window/GlResource.cpp
@@ -73,6 +73,13 @@ GlResource::~GlResource()
////////////////////////////////////////////////////////////
+void GlResource::ensureGlContext()
+{
+ // Empty function for ABI compatibility, use acquireTransientContext instead
+}
+
+
+////////////////////////////////////////////////////////////
GlResource::TransientContextLock::TransientContextLock() :
m_context(0)
{