summaryrefslogtreecommitdiff
path: root/debian/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'debian/tests/CMakeLists.txt')
-rw-r--r--debian/tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/debian/tests/CMakeLists.txt b/debian/tests/CMakeLists.txt
new file mode 100644
index 0000000..f265619
--- /dev/null
+++ b/debian/tests/CMakeLists.txt
@@ -0,0 +1,12 @@
+# Test CMake project to ensure FindSFML.cmake works properly
+
+cmake_minimum_required(VERSION 3.7.2)
+project(SFMLTest CXX)
+
+# Try to find SFML using CMake config file
+# Even though this test doesn't need them, request all components to check they exist
+find_package(SFML 2 COMPONENTS audio graphics network system window REQUIRED CONFIG)
+
+# Build the exexutable
+add_executable(sfml_test sfml_test.cpp)
+target_link_libraries(sfml_test sfml-network sfml-system)