summaryrefslogtreecommitdiff
path: root/src/SFML/System/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/SFML/System/Makefile')
-rwxr-xr-xsrc/SFML/System/Makefile34
1 files changed, 0 insertions, 34 deletions
diff --git a/src/SFML/System/Makefile b/src/SFML/System/Makefile
deleted file mode 100755
index 1cf6211..0000000
--- a/src/SFML/System/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-SRC = $(wildcard *.cpp ./Unix/*.cpp)
-OBJ = $(SRC:.cpp=.o)
-
-ifeq ($(STATIC), yes)
- LIB = libsfml-system-s.a
- LIBNAME = $(LIBPATH)/$(LIB)
- INSTALL =
-else
- LIB = libsfml-system.so
- LIBNAME = $(LIBPATH)/$(LIB).$(VERSION)
- INSTALL = && $(LN) $(LNFLAGS) $(LIB).$(VERSION) $(DESTLIBDIR)/$(LIB)
-endif
-
-all: $(LIB)
-
-libsfml-system-s.a: $(OBJ)
- $(AR) $(ARFLAGS) $(LIBNAME) $(OBJ)
-
-libsfml-system.so: $(OBJ)
- $(CPP) $(LDFLAGS) -Wl,-soname,$(LIB).$(VERSION) -o $(LIBNAME) $(OBJ) -lpthread
-
-$(OBJ): %.o: %.cpp
- $(CPP) -o $@ -c $< $(CFLAGS)
-
-.PHONY: clean mrproper
-
-clean:
- @rm -rf $(OBJ)
-
-mrproper: clean
- @rm -rf $(LIBNAME)
-
-install:
- @($(CP) $(LIBNAME) $(DESTLIBDIR) $(INSTALL))