summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Overmeer <mark@overmeer.net>2018-01-23 22:08:41 +0100
committerMark Overmeer <mark@overmeer.net>2018-01-23 22:08:41 +0100
commite3893b05a97e19411b1ebdf4c9d8da164273f1ec (patch)
treea2ac8b12f99f4c9d7b307d0aed9c63e2fe71fe4e
parent27eb43499fea2114591655067711222ee2981989 (diff)
convert GIT and GitHUB
-rw-r--r--ChangeLog6
-rw-r--r--MANIFEST1
-rw-r--r--Makefile.PL21
-rw-r--r--README.md59
-rw-r--r--lib/String/Print.pm9
5 files changed, 90 insertions, 6 deletions
diff --git a/ChangeLog b/ChangeLog
index a60e504..577371b 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,12 @@
========== version history of String::Print
+version 0.93: Tue Jan 23 22:08:31 CET 2018
+
+ Improvements:
+ - convert to GIT
+ - publish via GitHUB
+
version 0.92: Thu 6 Jul 12:31:36 CEST 2017
Fixes:
diff --git a/MANIFEST b/MANIFEST
index e196231..5e53feb 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -1,6 +1,7 @@
ChangeLog
MANIFEST
Makefile.PL
+README.md
lib/String/Print.pm
t/00use.t
t/10serial.t
diff --git a/Makefile.PL b/Makefile.PL
index 274f77d..5eb241c 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -2,7 +2,7 @@ use ExtUtils::MakeMaker;
use 5.010;
-my $version = '0.92';
+my $version = '0.93';
my %prereq =
( Test::More => 0.86
@@ -20,6 +20,19 @@ WriteMakefile
, AUTHOR => 'Mark Overmeer'
, ABSTRACT => 'printf extensions'
, LICENSE => 'perl'
+
+ , META_MERGE =>
+ { 'meta-spec' => { version => 2 }
+ , resources =>
+ { repository =>
+ { type => 'git'
+ , url => 'https://github.com/markov2/perl5-String-Print.git'
+ , web => 'https://github.com/markov2/perl5-String-Print'
+ }
+ }
+ , homepage => 'http://perl.overmeer.net/CPAN/'
+ , license => [ 'http://dev.perl.org/licenses/' ]
+ }
);
sub MY::postamble { <<'__POSTAMBLE' }
@@ -27,12 +40,12 @@ sub MY::postamble { <<'__POSTAMBLE' }
# for OODoc's oodist, DIST
RAWDIR = ../public_html/string-print/raw
DISTDIR = ../public_html/string-print/source
-LICENSE = artistic
+LICENSE = perl
# for OODoc's oodist, POD
FIRST_YEAR = 2016
-EMAIL = perl@overmeer.net
-WEBSITE = http://perl.overmeer.net/log-report/
+EMAIL = markov@cpan.org
+WEBSITE = http://perl.overmeer.net/CPAN/
EXTENDS =
__POSTAMBLE
diff --git a/README.md b/README.md
new file mode 100644
index 0000000..550de83
--- /dev/null
+++ b/README.md
@@ -0,0 +1,59 @@
+# distribution String-Print
+
+ * My extended documentation: <http://perl.overmeer.net/CPAN/>
+ * Development via GitHub: <https://github.com/markov2/perl5-String-Print>
+ * Download from CPAN: <ftp://ftp.cpan.org/pub/CPAN/authors/id/M/MA/MARKOV/>
+ * Indexed from CPAN: <http://search.cpan.org/~markov/String-Print/>
+ and <https://metacpan.org/release/String-Print>
+
+This module inserts values into (format) strings. It provides printf()
+and sprintf() alternatives via both an object oriented and a functional
+interface.
+
+## Development &rarr; Release
+
+Important to know, is that I use an extension on POD to write the manuals.
+The "raw" unprocessed version is visible on GitHub. It will run without
+problems, but does not contain manual-pages.
+
+Releases to CPAN are different: "raw" documentation gets removed from
+the code and translated into real POD and clean HTML. This reformatting
+is implemented with the OODoc distribution (A name I chose before OpenOffice
+existed, sorry for the confusion)
+
+Clone from github for the "raw" version. For instance, when you want
+to contribute a new feature.
+
+On github, you can find the processed version for each release. But the
+better source is CPAN; to get it installed simply run:
+
+```sh
+ cpan -i String::Print
+```
+
+## Contributing
+
+When you want to contribute to this module, you do not need to provide
+a perfect patch... actually: it is nearly impossible to create a patch
+which I will merge without modification. Usually, I need to adapt the
+style of code and documentation to my own strict rules.
+
+When you submit an extension, please contribute a set with
+
+1. code
+
+2. code documentation
+
+3. regression tests in t/
+
+**Please note:**
+When you contribute in any way, you agree to transfer the copyrights to
+Mark Overmeer (you will get the honors in the code and/or ChangeLog).
+You also automatically agree that your contribution is released under
+the same license as this project: licensed as perl itself.
+
+## Copyright and License
+
+This project is free software; you can redistribute it and/or modify it
+under the same terms as Perl itself.
+See <http://dev.perl.org/licenses/>
diff --git a/lib/String/Print.pm b/lib/String/Print.pm
index b6ee4e1..8da1883 100644
--- a/lib/String/Print.pm
+++ b/lib/String/Print.pm
@@ -1,8 +1,12 @@
-use warnings;
-use strict;
+# This code is part of distribution String-Print. Meta-POD processed with
+# OODoc into POD and HTML manual-pages. See README.md
+# Copyright Mark Overmeer. Licensed under the same terms as Perl itself.
package String::Print;
+use warnings;
+use strict;
+
#use Log::Report::Optional 'log-report';
use Encode qw/is_utf8 decode/;
@@ -1223,6 +1227,7 @@ provided per explicit function call. Only C<String::Print> cleanly
separates the roles of serializers, modifiers, and conversions.
C<String::Print> is nicely integrated with M<Log::Report>.
+
=cut
1;