summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2023-08-11 16:28:19 +0200
committergregor herrmann <gregoa@debian.org>2023-08-11 16:28:19 +0200
commit1bd963c280e59d29249411ed94e5c7e632cff3f4 (patch)
tree104ba49cbc765d22b4756ad67e4563add4a5c465
parentda0c30da9ceff3d92b6ed634eef80868be661ffd (diff)
New upstream version 0.13+dfsg
-rw-r--r--Build.PL5
-rw-r--r--Changes12
-rw-r--r--MANIFEST3
-rw-r--r--META.json17
-rw-r--r--META.yml31
-rw-r--r--Makefile.PL2
-rw-r--r--README2
-rw-r--r--lib/App/Prove/Plugin/HTML.pm4
-rw-r--r--lib/TAP/Formatter/HTML.pm17
-rw-r--r--lib/TAP/Formatter/HTML/Session.pm2
-rw-r--r--lib/TAP/Formatter/HTML/default_report.tt22
-rw-r--r--t/11_force_inline.t4
12 files changed, 66 insertions, 35 deletions
diff --git a/Build.PL b/Build.PL
index 5995ff8..1a2d462 100644
--- a/Build.PL
+++ b/Build.PL
@@ -37,6 +37,11 @@ my $build = Module::Build->new
'Test::More' => '0.01',
'Module::Build' => '0.20',
},
+ meta_merge => {
+ resources => {
+ repository => 'https://github.com/spurkis/TAP-Formatter-HTML'
+ }
+ },
);
$build->add_build_element("tt2");
diff --git a/Changes b/Changes
index c0c5ad3..395baf1 100644
--- a/Changes
+++ b/Changes
@@ -3,6 +3,18 @@ Revision history for 'TAP-Formatter-HTML' Perl module
All changes by Steve Purkis, unless otherwise noted.
+0.13
+ + fix calculating todo_passed tests, GH#7 (tu-maurice)
+ + applied several tweaks from RT and Github:
+ RT#132072: more international ISO8601-like date format (Slaven Rezić)
+ RT#91317: synopsis of main module and plugin (Slaven Rezić)
+ RT#89216: typo fix (dsteinbrunner)
+ GH#2: gitignore (Gábor Szabó)
+ GH#4: fix double include of css and javascript (Christopher Rasch-Olsen Raa)
+
+0.12
+ + intermediate upload with incomplete changelog
+
0.11
+ fixed RT #81922: tests no longer hang on Win32. Didn't get to the bottom
of the issue (likely IPC::Open3 & redirecting STDOUT not playing nicely),
diff --git a/MANIFEST b/MANIFEST
index 90d11a7..67fb590 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -1,6 +1,7 @@
Build.PL
Changes
examples/DBD-SQLite-example.html
+examples/jquery-1.2.3.pack.js
examples/test-output.html
lib/App/Prove/Plugin/HTML.pm
lib/TAP/Formatter/HTML.pm
@@ -8,6 +9,8 @@ lib/TAP/Formatter/HTML/default_page.css
lib/TAP/Formatter/HTML/default_report.css
lib/TAP/Formatter/HTML/default_report.js
lib/TAP/Formatter/HTML/default_report.tt2
+lib/TAP/Formatter/HTML/jquery-1.4.2.min.js
+lib/TAP/Formatter/HTML/jquery.tablesorter-2.0.3.min.js
lib/TAP/Formatter/HTML/Session.pm
Makefile.PL
MANIFEST This list of files
diff --git a/META.json b/META.json
index de065b0..a7c0752 100644
--- a/META.json
+++ b/META.json
@@ -4,7 +4,7 @@
"Steve Purkis <spurkis@cpan.org>"
],
"dynamic_config" : 1,
- "generated_by" : "Module::Build version 0.38, CPAN::Meta::Converter version 2.113640",
+ "generated_by" : "Module::Build version 0.4214",
"license" : [
"perl_5"
],
@@ -22,7 +22,7 @@
},
"configure" : {
"requires" : {
- "Module::Build" : "0.38"
+ "Module::Build" : "0.42"
}
},
"runtime" : {
@@ -40,22 +40,25 @@
"provides" : {
"App::Prove::Plugin::HTML" : {
"file" : "lib/App/Prove/Plugin/HTML.pm",
- "version" : "0.11"
+ "version" : "0.13"
},
"TAP::Formatter::HTML" : {
"file" : "lib/TAP/Formatter/HTML.pm",
- "version" : "0.11"
+ "version" : "0.13"
},
"TAP::Formatter::HTML::Session" : {
"file" : "lib/TAP/Formatter/HTML/Session.pm",
- "version" : "0.11"
+ "version" : "0.13"
}
},
"release_status" : "stable",
"resources" : {
"license" : [
"http://dev.perl.org/licenses/"
- ]
+ ],
+ "repository" : {
+ "url" : "https://github.com/spurkis/TAP-Formatter-HTML"
+ }
},
- "version" : "0.11"
+ "version" : "0.13"
}
diff --git a/META.yml b/META.yml
index 3859868..e6bcc60 100644
--- a/META.yml
+++ b/META.yml
@@ -3,35 +3,36 @@ abstract: 'TAP Test Harness output delegate for html output'
author:
- 'Steve Purkis <spurkis@cpan.org>'
build_requires:
- Module::Build: 0.20
- Test::More: 0.01
+ Module::Build: '0.20'
+ Test::More: '0.01'
configure_requires:
- Module::Build: 0.38
+ Module::Build: '0.42'
dynamic_config: 1
-generated_by: 'Module::Build version 0.38, CPAN::Meta::Converter version 2.113640'
+generated_by: 'Module::Build version 0.4214, CPAN::Meta::Converter version 2.150001'
license: perl
meta-spec:
url: http://module-build.sourceforge.net/META-spec-v1.4.html
- version: 1.4
+ version: '1.4'
name: TAP-Formatter-HTML
provides:
App::Prove::Plugin::HTML:
file: lib/App/Prove/Plugin/HTML.pm
- version: 0.11
+ version: '0.13'
TAP::Formatter::HTML:
file: lib/TAP/Formatter/HTML.pm
- version: 0.11
+ version: '0.13'
TAP::Formatter::HTML::Session:
file: lib/TAP/Formatter/HTML/Session.pm
- version: 0.11
+ version: '0.13'
requires:
- File::Temp: 0.17
- TAP::Parser: 3.10
- Template: 2.14
- Test::Harness: 3.17
- URI: 1.35
- accessors: 0.02
+ File::Temp: '0.17'
+ TAP::Parser: '3.10'
+ Template: '2.14'
+ Test::Harness: '3.17'
+ URI: '1.35'
+ accessors: '0.02'
perl: v5.6.0
resources:
license: http://dev.perl.org/licenses/
-version: 0.11
+ repository: https://github.com/spurkis/TAP-Formatter-HTML
+version: '0.13'
diff --git a/Makefile.PL b/Makefile.PL
index d32a25a..ce9cf56 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -1,4 +1,4 @@
-# Note: this file was auto-generated by Module::Build::Compat version 0.3800
+# Note: this file was auto-generated by Module::Build::Compat version 0.4214
require 5.006000;
unless (eval "use Module::Build::Compat 0.02; 1" ) {
diff --git a/README b/README
index 29af679..7dcbed1 100644
--- a/README
+++ b/README
@@ -342,7 +342,7 @@ WIN32 URIS
look for a signature 'X:\', '\' or 'file:' at the start of each URI to
see if you are referring to a file or another type of URI.
- Note that you must use '"file:///C:\blah"' with *3 slashes* otherwie
+ Note that you must use '"file:///C:\blah"' with *3 slashes* otherwise
'"C:"' will become your *host*, which is probably not what you want. See
URI::file for more details.
diff --git a/lib/App/Prove/Plugin/HTML.pm b/lib/App/Prove/Plugin/HTML.pm
index 6887532..4757694 100644
--- a/lib/App/Prove/Plugin/HTML.pm
+++ b/lib/App/Prove/Plugin/HTML.pm
@@ -7,7 +7,7 @@ App::Prove::Plugin::HTML - a prove plugin for HTML output
=head1 SYNOPSIS
# command-line usage:
- prove -P HTML=outfile:out.html,css_uri:style.css,js_uri:foo.js,force_inline_css:0
+ prove -m -P HTML=outfile:out.html,css_uri:style.css,js_uri:foo.js,force_inline_css:0
# NOTE: this is currently in alpha, this usage will likely change!
@@ -18,7 +18,7 @@ use warnings;
use TAP::Formatter::HTML;
-our $VERSION = '0.11';
+our $VERSION = '0.13';
sub import {
my ($class, @args) = @_;
diff --git a/lib/TAP/Formatter/HTML.pm b/lib/TAP/Formatter/HTML.pm
index 6a6bbd7..35a915c 100644
--- a/lib/TAP/Formatter/HTML.pm
+++ b/lib/TAP/Formatter/HTML.pm
@@ -95,7 +95,7 @@ use constant severity_map => {
5 => 'very-high',
};
-our $VERSION = '0.11';
+our $VERSION = '0.13';
our $FAKE_WIN32_URIS = 0; # for testing only
sub _initialize {
@@ -278,8 +278,14 @@ sub generate_report {
my ($self, $r) = @_;
$self->check_uris;
- $self->slurp_css if $self->force_inline_css;
- $self->slurp_js if $self->force_inline_js;
+ if($self->force_inline_css) {
+ $self->slurp_css;
+ $self->css_uris([]);
+ }
+ if($self->force_inline_js) {
+ $self->slurp_js;
+ $self->js_uris([]);
+ }
my $params = {
report => $r,
@@ -378,9 +384,8 @@ sub prepare_report {
}
# do some other handy calcs:
- $r->{actual_passed} = $r->{passed} + $r->{todo_passed};
if ($r->{total}) {
- $r->{percent_passed} = sprintf('%.1f', $r->{actual_passed} / $r->{total} * 100);
+ $r->{percent_passed} = sprintf('%.1f', $r->{passed} / $r->{total} * 100);
} else {
$r->{percent_passed} = 0;
}
@@ -864,7 +869,7 @@ Unix. So if you're running under Win32, C<TAP::Formatter::HTML> will look for
a signature C<'X:\'>, C<'\'> or C<'file:'> at the start of each URI to see if
you are referring to a file or another type of URI.
-Note that you must use 'C<file:///C:\blah>' with I<3 slashes> otherwie 'C<C:>'
+Note that you must use 'C<file:///C:\blah>' with I<3 slashes> otherwise 'C<C:>'
will become your I<host>, which is probably not what you want. See
L<URI::file> for more details.
diff --git a/lib/TAP/Formatter/HTML/Session.pm b/lib/TAP/Formatter/HTML/Session.pm
index 474494b..c488b37 100644
--- a/lib/TAP/Formatter/HTML/Session.pm
+++ b/lib/TAP/Formatter/HTML/Session.pm
@@ -19,7 +19,7 @@ use warnings;
use base qw( TAP::Base );
use accessors qw( test formatter parser results html_id meta closed );
-our $VERSION = '0.11';
+our $VERSION = '0.13';
sub _initialize {
my ($self, $args) = @_;
diff --git a/lib/TAP/Formatter/HTML/default_report.tt2 b/lib/TAP/Formatter/HTML/default_report.tt2
index ab664a1..fc00e5a 100644
--- a/lib/TAP/Formatter/HTML/default_report.tt2
+++ b/lib/TAP/Formatter/HTML/default_report.tt2
@@ -164,7 +164,7 @@ Developer Notes:
</table>
</div>
- <div id="footer">Generated by [% formatter.class %] v[% formatter.version %] @ [% USE date %][% date.format %]</div>
+ <div id="footer">Generated by [% formatter.class %] v[% formatter.version %] @ [% USE date %][% date.format(date.now, "%F %T") %]</div>
</body>
</html>
diff --git a/t/11_force_inline.t b/t/11_force_inline.t
index 071eefd..a0ec106 100644
--- a/t/11_force_inline.t
+++ b/t/11_force_inline.t
@@ -4,7 +4,7 @@ use warnings;
use lib 'lib';
use lib 't/lib';
-use Test::More 'no_plan';
+use Test::More tests => 8;
use FileTempTFH;
use TAP::Harness;
@@ -26,3 +26,5 @@ ok( $html =~ qr|default javascript for report|, 'html contains default js' );
ok( $html =~ qr|default stylesheet for report body|, 'html contains default css body' );
ok( $html =~ qr|default stylesheet for report page layout|, 'html contains default css page' );
+ok( $html !~ qr|href=".+/TAP/Formatter/HTML/default_report\.css"|, 'html does not contain links to css files' );
+ok( $html !~ qr|src=".+/TAP/Formatter/HTML/jquery-1\.4\.2\.min\.js"|, 'html does not contain links to js files' );