summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul "LeoNerd" Evans <leonerd@leonerd.org.uk>2020-05-16 14:01:01 +0100
committerPaul "LeoNerd" Evans <leonerd@leonerd.org.uk>2020-05-16 14:01:01 +0100
commit07a9fdaf5a9af79a0b5ada0dfe04c0ba8f60934c (patch)
tree01424b205c52c69957e6ca23bfe84ab810c5aba3
parentee08289764a81e4df904a0ff8f8fbd31dbce1613 (diff)
Bumped version to 0.4.0-RC1; updated CHANGES notes
-rw-r--r--CHANGES10
-rw-r--r--Makefile4
-rw-r--r--include/tickit.h4
-rw-r--r--tickit.pc.sh2
4 files changed, 15 insertions, 5 deletions
diff --git a/CHANGES b/CHANGES
index cd4fa19..f3622e8 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,13 @@
+2020-05-16 0.4.0-RC1
+ * Expose TickitBuilder and TickitTermBuilder as API-visible structs
+ * Added tickit_build(3) and tickit_term_build(3)
+ * Added tickit_new_stdtty(3)
+ * Optionally parse a secondary RGB8 colour specification in
+ tickit_pen_set_colour_attr_desc(3)
+ * Accept colour desc strings in tickit_pen_new_attrs(3)
+ * Added TICKIT_BIND_ONESHOT event-binding flag
+ * Added tickit_watch_io(3)
+
2020-03-02 19:09 0.3.5
* Copied wcwidth() implementation from libvterm, for improved handling of
emoji characters and other fullwidth or wide characters (LP1865502)
diff --git a/Makefile b/Makefile
index d7f3d25..90e2673 100644
--- a/Makefile
+++ b/Makefile
@@ -44,8 +44,8 @@ TESTFILES=$(TESTSOURCES:.c=.t)
EXAMPLESOURCES=$(sort $(wildcard examples/*.c))
-VERSION_CURRENT=2
-VERSION_REVISION=5
+VERSION_CURRENT=3
+VERSION_REVISION=0
VERSION_AGE=0
PREFIX=/usr/local
diff --git a/include/tickit.h b/include/tickit.h
index b618c5b..5691771 100644
--- a/include/tickit.h
+++ b/include/tickit.h
@@ -25,8 +25,8 @@ extern "C" {
#endif
#define TICKIT_VERSION_MAJOR 0
-#define TICKIT_VERSION_MINOR 3
-#define TICKIT_VERSION_PATCH 5
+#define TICKIT_VERSION_MINOR 4
+#define TICKIT_VERSION_PATCH 0
int tickit_version_major(void);
int tickit_version_minor(void);
diff --git a/tickit.pc.sh b/tickit.pc.sh
index 059c428..4a80418 100644
--- a/tickit.pc.sh
+++ b/tickit.pc.sh
@@ -9,7 +9,7 @@ includedir=$INCDIR
Name: tickit
Description: Terminal Interface Construction KIT
-Version: 0.3.5
+Version: 0.4.0-RC1
Libs: $LIBS
Cflags: $CFLAGS
EOF