summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames McCoy <jamessan@debian.org>2018-10-15 22:24:31 -0400
committerJames McCoy <jamessan@debian.org>2018-10-15 22:24:31 -0400
commit4a91b7cfbe52820acc98c046064154c4ad3c5cf9 (patch)
treeb417640e18f9737c5c97825358f81aadeeda5f73
parentd0db4eac5fa977a4354236b1549aba7ba6fd2273 (diff)
Suppress build output when DEB_BUILD_OPTIONS=terse
Signed-off-by: James McCoy <jamessan@debian.org>
-rwxr-xr-xdebian/rules11
1 files changed, 8 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 6cfba59..800e8eb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,16 +8,21 @@ include /usr/share/dpkg/default.mk
CFLAGS += $(CPPFLAGS)
export CFLAGS LDFLAGS
+VERBOSE=
+ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
+ VERBOSE=VERBOSE=1
+endif
+
%:
dh $@
override_dh_auto_build-arch:
- $(MAKE) VERBOSE=1 PREFIX=/usr LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH)
+ $(MAKE) $(VERBOSE) PREFIX=/usr LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH)
override_dh_auto_install-arch:
- $(MAKE) VERBOSE=1 PREFIX=/usr LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) DESTDIR=$(CURDIR)/debian/tmp install
+ $(MAKE) $(VERBOSE) PREFIX=/usr LIBDIR=/usr/lib/$(DEB_HOST_MULTIARCH) DESTDIR=$(CURDIR)/debian/tmp install
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- env TERM=xterm $(MAKE) VERBOSE=1 test
+ env TERM=xterm $(MAKE) $(VERBOSE) test
endif