summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2020-10-31 14:56:57 +0100
committergregor herrmann <gregoa@debian.org>2020-10-31 14:56:57 +0100
commit2a0c3f7498f2dbdbc71d449c6b785b4275de202a (patch)
tree1f720bbf89da0f9497ec8a40b99d5c1e5accfb93
parent5f90ae2f345e881e27a822d737aba0a3fb373412 (diff)
New upstream version 1.26
-rw-r--r--Changes8
-rw-r--r--META.json9
-rw-r--r--META.yml4
-rw-r--r--Makefile.PL18
-rw-r--r--TableMatrix.pm2
-rw-r--r--TableMatrix/Spreadsheet.pm2
-rw-r--r--TableMatrix/SpreadsheetHideRows.pm2
-rw-r--r--pTk/MYMETA.json2
-rw-r--r--pTk/MYMETA.yml2
-rw-r--r--pTk/Makefile.PL26
-rw-r--r--pTk/counts2
-rw-r--r--pTk/mkmethods2
-rw-r--r--pod/TableMatrix.pod6
13 files changed, 49 insertions, 36 deletions
diff --git a/Changes b/Changes
index 0f67224..8af5a08 100644
--- a/Changes
+++ b/Changes
@@ -2,6 +2,14 @@ Summary of Changes to Tk::TableMatrix
See ChangeLog for detailed changes.
+Release 1.26 10/26/2020
+
+* Fix RT #133587: improper handling of line endings differing from `$/`
+ in pTk.exc files causes build failure (tries compiling
+ known-uncompilable files—e.g. tkAppInit.c, tkTablePs.c)
+* Add GitHub repository to module metadata
+* Apply POD fixes (originally by Debian package maintainer Bart Martens)
+
Release 1.25 10/19/2020
* add dependencies / RT #133557
diff --git a/META.json b/META.json
index 4a966e5..ebc70d8 100644
--- a/META.json
+++ b/META.json
@@ -39,6 +39,13 @@
}
},
"release_status" : "stable",
- "version" : "1.25",
+ "resources" : {
+ "repository" : {
+ "type" : "git",
+ "url" : "https://github.com/asb-capfan/Tk-TableMatrix.git",
+ "web" : "https://github.com/asb-capfan/Tk-TableMatrix"
+ }
+ },
+ "version" : "1.26",
"x_serialization_backend" : "JSON::PP version 4.04"
}
diff --git a/META.yml b/META.yml
index eccd6d4..9989f97 100644
--- a/META.yml
+++ b/META.yml
@@ -21,5 +21,7 @@ no_index:
- inc
requires:
Tk: '800.022'
-version: '1.25'
+resources:
+ repository: https://github.com/asb-capfan/Tk-TableMatrix.git
+version: '1.26'
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff --git a/Makefile.PL b/Makefile.PL
index 4d45f4e..7eeae0a 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -9,7 +9,7 @@ BEGIN
$IsWin32 = ($^O eq 'MSWin32' || $Config{'ccflags'} =~ /-D_?WIN32_?/);
- $VERSION = '1.25';
+ $VERSION = '1.26';
$win_arch = shift @ARGV if @ARGV and $ARGV[0] =~ /^(open32|pm|x|MSWin32)$/;
require('fix_4_os2.pl'), OS2_massage() if $^O eq 'os2';
@@ -88,8 +88,18 @@ Tk::MMutil::TkExtMakefile(
},
'CONFIGURE_REQUIRES' => {
"ExtUtils::MakeMaker" => 6.52,
- Tk::MMtry => 0,
- Tk::MMutil => 0,
+ "Tk::MMtry" => 0,
+ "Tk::MMutil" => 0,
+ },
+ 'META_MERGE' => {
+ "meta-spec" => { version => 2 },
+ resources => {
+ repository => {
+ type => 'git',
+ url => 'https://github.com/asb-capfan/Tk-TableMatrix.git',
+ web => 'https://github.com/asb-capfan/Tk-TableMatrix',
+ },
+ },
},
@macro
);
@@ -142,7 +152,7 @@ sub needs_Test
my $code = 0;
while (<TFILE>)
{
- last if ($code = /^\s*(use|require)\s+Test\b/);
+ last if ($code = m/^\s*(use|require)\s+Test\b/);
}
close(TFILE);
warn "Skipping test $file needs 'Test.pm':$_" if $code;
diff --git a/TableMatrix.pm b/TableMatrix.pm
index a08cea8..5f3e860 100644
--- a/TableMatrix.pm
+++ b/TableMatrix.pm
@@ -28,7 +28,7 @@ use Carp;
use strict;
use vars( '%tkPriv', '$VERSION');
-$VERSION = '1.25';
+$VERSION = '1.26';
use Tk qw( Ev );
diff --git a/TableMatrix/Spreadsheet.pm b/TableMatrix/Spreadsheet.pm
index 5a9068d..be1356b 100644
--- a/TableMatrix/Spreadsheet.pm
+++ b/TableMatrix/Spreadsheet.pm
@@ -94,7 +94,7 @@ use Tk::Derived;
use base qw/ Tk::Derived Tk::TableMatrix/;
-$VERSION = '1.25';
+$VERSION = '1.26';
Tk::Widget->Construct("Spreadsheet");
diff --git a/TableMatrix/SpreadsheetHideRows.pm b/TableMatrix/SpreadsheetHideRows.pm
index 42f4702..ca592a6 100644
--- a/TableMatrix/SpreadsheetHideRows.pm
+++ b/TableMatrix/SpreadsheetHideRows.pm
@@ -120,7 +120,7 @@ use Tk::Derived;
use base qw/ Tk::Derived Tk::TableMatrix::Spreadsheet/;
-$VERSION = '1.25';
+$VERSION = '1.26';
Tk::Widget->Construct("SpreadsheetHideRows");
diff --git a/pTk/MYMETA.json b/pTk/MYMETA.json
index 5afa0ac..cd2923d 100644
--- a/pTk/MYMETA.json
+++ b/pTk/MYMETA.json
@@ -32,6 +32,6 @@
}
},
"release_status" : "stable",
- "version" : "1.25",
+ "version" : "1.26",
"x_serialization_backend" : "JSON::PP version 4.04"
}
diff --git a/pTk/MYMETA.yml b/pTk/MYMETA.yml
index ce03f3a..e31dd5c 100644
--- a/pTk/MYMETA.yml
+++ b/pTk/MYMETA.yml
@@ -17,5 +17,5 @@ no_index:
directory:
- t
- inc
-version: '1.25'
+version: '1.26'
x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff --git a/pTk/Makefile.PL b/pTk/Makefile.PL
index dd4bc6c..8b9f149 100644
--- a/pTk/Makefile.PL
+++ b/pTk/Makefile.PL
@@ -27,7 +27,7 @@ $ptkPath =~ s/\/Lang.h$//g;
Tk::MMutil::TkExtMakefile(
'NAME' => 'Tk::pTk',
- 'VERSION' => '1.25',
+ 'VERSION' => '1.26',
'XS_VERSION'=> '0.9',
'LINKTYPE' => 'static',
'OBJECT' => '$(O_FILES)',
@@ -55,23 +55,7 @@ sub MY::post_initialize
my ($self) = @_;
my %mTk;
my $dir;
- my @list;
- if ($Tk::MMutil::IsWin32)
- { # only Tktable needed for everything
- @list = ($mTkDir);
- }
- elsif ($win_arch eq 'open32')
- {
- @list = ($mTkDir);
- }
- elsif ($win_arch eq 'pm')
- {
- @list = ($mTkDir);
- }
- else
- {
- @list = ($mTkDir);
- }
+ my @list = ($mTkDir);
print STDERR "Generating Dependencies for $^O, win_arch=$win_arch\n";
foreach $dir (@list)
{
@@ -82,7 +66,7 @@ sub MY::post_initialize
{
while (<EXC>)
{
- chomp;
+ s/\s+$//s;
s/#.*$//;
next unless /\S/;
$mTk{$_} = $self->catfile($src,$_) unless (exists $mTk{$_});
@@ -96,7 +80,7 @@ sub MY::post_initialize
{
while (<EXC>)
{
- chomp;
+ s/\s+$//s;
s/#.*$//;
next unless /\S/;
$exc{$_} = 1;
@@ -236,7 +220,7 @@ sub MY::postamble {
$dep .= $self->dir_target(@{$self->{'dir_targets'}});
- # add some additional dir targets - reason currently unknown. Use $(DFSEP) as dir separatir or makefile will not find target (target uses $(DFSEP) too).
+ # add some additional dir targets - reason currently unknown. Use $(DFSEP) as dir separator or makefile will not find target (target uses $(DFSEP) too).
$dep .= "config :: " . join(" \\\n\t",map($_.'$(DFSEP).exists',@{$self->{'dir_targets'}})) .
"\n\t".$self->{NOECHO}."\$(NOOP)\n";
diff --git a/pTk/counts b/pTk/counts
index 5e04ab1..6e0c014 100644
--- a/pTk/counts
+++ b/pTk/counts
@@ -10,7 +10,7 @@ sub count
while (<C>)
{
next if (/^\s*$/);
- $match = /$file/ if (/^#/);
+ $match = m/$file/ if (/^#/);
if ($match)
{
study;
diff --git a/pTk/mkmethods b/pTk/mkmethods
index a2808b6..1cac5e5 100644
--- a/pTk/mkmethods
+++ b/pTk/mkmethods
@@ -80,7 +80,7 @@ if (%{$table{WIDGET}} || %{$table{COMMAND}} || %{$table{IMAGE}})
{
while (<SRC>)
{
- my ($kind,$Widget,$list) = /^(WIDGET|COMMAND|IMAGE)\(\("(\w+)",(("[^"]*",)*)NULL\)\)$/;
+ my ($kind,$Widget,$list) = m/^(WIDGET|COMMAND|IMAGE)\(\("(\w+)",(("[^"]*",)*)NULL\)\)$/;
if (defined $Widget)
{
if (!defined ${$table{$kind}}{$Widget})
diff --git a/pod/TableMatrix.pod b/pod/TableMatrix.pod
index dcc5ab8..9316548 100644
--- a/pod/TableMatrix.pod
+++ b/pod/TableMatrix.pod
@@ -1337,10 +1337,10 @@ without affecting the selection state of cells outside that range.
=back
-=over 1
-
perltk note this needs to be perlized
+=over 1
+
=item I<$table>-E<gt>B<set>(?I<row|col>?, I<index>, ?I<value>?, ?I<index, value, ...>?)
@@ -1605,6 +1605,8 @@ become visible.
=back
+=back
+
=head1 Default Bindings
The initialization creates class bindings