summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeon Timmermans <fawaka@gmail.com>2020-08-02 14:30:31 +0200
committerLeon Timmermans <fawaka@gmail.com>2020-08-02 14:30:31 +0200
commit61f86fa413a9ca2b0e3075196998da7c802f7128 (patch)
tree6694e958e10f8010f4137741bd3882e51e68e3e2
parent6558f0053090df3f9a6ec9f0921293191b9d86e4 (diff)
Bump to 0.99_25
-rw-r--r--CHANGES6
-rw-r--r--Makefile.PL2
-rw-r--r--README2
-rw-r--r--lib/version.pm2
-rw-r--r--lib/version/regex.pm2
-rw-r--r--t/00impl-pp.t2
-rw-r--r--t/01base.t2
-rw-r--r--t/02derived.t2
-rw-r--r--t/03require.t2
-rw-r--r--t/05sigdie.t2
-rw-r--r--t/06noop.t2
-rw-r--r--t/07locale.t2
-rw-r--r--t/08_corelist.t2
-rw-r--r--t/09_list_util.t2
-rw-r--r--vperl/vpp.pm2
-rw-r--r--vutil/lib/version/vxs.pm2
16 files changed, 21 insertions, 15 deletions
diff --git a/CHANGES b/CHANGES
index c17a419..3502d1a 100644
--- a/CHANGES
+++ b/CHANGES
@@ -4,6 +4,12 @@ This is not a complete list of changes. See repository for full details:
https://github.com/JohnPeacock/version.pm.git
+0.99_25
+ * Fix stack usage in vcmp method
+ * Drop Perl 5.5 compatibility
+ * Use PERL_VERSION_GE for Perl 7 compatibility
+ * Fix typo in pod example for comparing versions.
+
0.9924 - 2018-04-19
* Revise CPAN metadata to advertise correct repo
Patch from Ed <ej_zg@hotmail.com>
diff --git a/Makefile.PL b/Makefile.PL
index 4219339..e8ca218 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -52,7 +52,7 @@ sub write_makefile
'parent' => 0.221,
);
- WriteMakefile( VERSION => '0.9924',
+ WriteMakefile( VERSION => '0.99_25',
NAME => 'version',
LICENSE => 'perl',
MIN_PERL_VERSION=> 5.006002,
diff --git a/README b/README
index 9073890..046f51a 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-version 0.9924
+version 0.9925
==================================
Object oriented versions for all Perl releases from 5.6.2 onward. Replaces
diff --git a/lib/version.pm b/lib/version.pm
index 378a765..91ca1e6 100644
--- a/lib/version.pm
+++ b/lib/version.pm
@@ -8,7 +8,7 @@ if ($] >= 5.015) {
warnings::register_categories(qw/version/);
}
-our $VERSION = 0.9924;
+our $VERSION = 0.99_25;
our $CLASS = 'version';
our (@ISA, $STRICT, $LAX);
diff --git a/lib/version/regex.pm b/lib/version/regex.pm
index dd9103c..fb3df99 100644
--- a/lib/version/regex.pm
+++ b/lib/version/regex.pm
@@ -2,7 +2,7 @@ package version::regex;
use strict;
-our $VERSION = 0.9924;
+our $VERSION = 0.99_25;
#--------------------------------------------------------------------------#
# Version regexp components
diff --git a/t/00impl-pp.t b/t/00impl-pp.t
index 4f893c1..e640d1d 100644
--- a/t/00impl-pp.t
+++ b/t/00impl-pp.t
@@ -14,7 +14,7 @@ BEGIN {
)
);
require $coretests;
- use_ok('version::vpp', 0.9924);
+ use_ok('version::vpp', 0.9925);
}
BaseTests("version::vpp","new","qv");
diff --git a/t/01base.t b/t/01base.t
index 2bac73b..fd97801 100644
--- a/t/01base.t
+++ b/t/01base.t
@@ -14,7 +14,7 @@ BEGIN {
)
);
require $coretests;
- use_ok('version', 0.9924);
+ use_ok('version', 0.9925);
}
BaseTests("version","new","qv");
diff --git a/t/02derived.t b/t/02derived.t
index a8da5b8..1d24888 100644
--- a/t/02derived.t
+++ b/t/02derived.t
@@ -15,7 +15,7 @@ BEGIN {
)
);
require $coretests;
- use_ok("version", 0.9924);
+ use_ok("version", 0.9925);
# If we made it this far, we are ok.
}
diff --git a/t/03require.t b/t/03require.t
index a28b897..ff0bdc3 100644
--- a/t/03require.t
+++ b/t/03require.t
@@ -19,7 +19,7 @@ BEGIN {
# Don't want to use, because we need to make sure that the import doesn't
# fire just yet (some code does this to avoid importing qv() and delare()).
require_ok("version");
-is $version::VERSION, 0.9924, "Make sure we have the correct class";
+is $version::VERSION, 0.9925, "Make sure we have the correct class";
ok(!"main"->can("qv"), "We don't have the imported qv()");
ok(!"main"->can("declare"), "We don't have the imported declare()");
diff --git a/t/05sigdie.t b/t/05sigdie.t
index 399739c..10cb4bc 100644
--- a/t/05sigdie.t
+++ b/t/05sigdie.t
@@ -14,7 +14,7 @@ BEGIN {
}
BEGIN {
- use version 0.9924;
+ use version 0.9925;
}
pass "Didn't get caught by the wrong DIE handler, which is a good thing";
diff --git a/t/06noop.t b/t/06noop.t
index 7db76ce..62aabba 100644
--- a/t/06noop.t
+++ b/t/06noop.t
@@ -7,7 +7,7 @@
use Test::More qw/no_plan/;
BEGIN {
- use_ok('version', 0.9924);
+ use_ok('version', 0.9925);
}
my $v1 = version->new('1.2');
diff --git a/t/07locale.t b/t/07locale.t
index fa34275..ba7956e 100644
--- a/t/07locale.t
+++ b/t/07locale.t
@@ -11,7 +11,7 @@ use Test::More tests => 8;
use Config;
BEGIN {
- use_ok('version', 0.9924);
+ use_ok('version', 0.9925);
}
SKIP: {
diff --git a/t/08_corelist.t b/t/08_corelist.t
index 86398b0..6b6550d 100644
--- a/t/08_corelist.t
+++ b/t/08_corelist.t
@@ -5,7 +5,7 @@
#########################
use Test::More tests => 3;
-use_ok("version", 0.9924);
+use_ok("version", 0.9925);
# do strict lax tests in a sub to isolate a package to test importing
SKIP: {
diff --git a/t/09_list_util.t b/t/09_list_util.t
index 63ff667..fa49c72 100644
--- a/t/09_list_util.t
+++ b/t/09_list_util.t
@@ -4,7 +4,7 @@
#########################
use strict;
-use_ok("version", 0.9924);
+use_ok("version", 0.9925);
use Test::More;
BEGIN {
diff --git a/vperl/vpp.pm b/vperl/vpp.pm
index dbf2fbb..5097d42 100644
--- a/vperl/vpp.pm
+++ b/vperl/vpp.pm
@@ -123,7 +123,7 @@ use warnings::register;
use Config;
-our $VERSION = 0.9924;
+our $VERSION = 0.99_25;
our $CLASS = 'version::vpp';
our ($LAX, $STRICT, $WARN_CATEGORY);
diff --git a/vutil/lib/version/vxs.pm b/vutil/lib/version/vxs.pm
index ae989cf..2e20c93 100644
--- a/vutil/lib/version/vxs.pm
+++ b/vutil/lib/version/vxs.pm
@@ -4,7 +4,7 @@ package version::vxs;
use v5.10;
use strict;
-our $VERSION = 0.9924;
+our $VERSION = 0.99_25;
our $CLASS = 'version::vxs';
our @ISA;