summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Peacock <john.peacock@havurah-software.org>2018-04-11 19:51:32 -0400
committerJohn Peacock <john.peacock@havurah-software.org>2018-04-11 19:51:32 -0400
commitc0c1c32f7514ede44069e12cdcf553cbefe48091 (patch)
tree3f72634cd0b5400ec658fa8782d72ef44448878b
parent70188e4468c761df412667f7e895aaaafc198a0c (diff)
Prep for release to CPAN
-rw-r--r--CHANGES2
-rw-r--r--Makefile.PL2
-rw-r--r--README2
-rw-r--r--lib/version.pm2
-rw-r--r--lib/version/regex.pm2
-rw-r--r--t/00impl-pp.t2
-rw-r--r--t/01base.t2
-rw-r--r--t/02derived.t2
-rw-r--r--t/03require.t2
-rw-r--r--t/05sigdie.t2
-rw-r--r--t/06noop.t2
-rw-r--r--t/07locale.t2
-rw-r--r--t/08_corelist.t2
-rw-r--r--t/09_list_util.t2
-rw-r--r--vperl/vpp.pm2
-rw-r--r--vutil/lib/version/vxs.pm2
16 files changed, 16 insertions, 16 deletions
diff --git a/CHANGES b/CHANGES
index 0a7f614..e712623 100644
--- a/CHANGES
+++ b/CHANGES
@@ -4,7 +4,7 @@ This is not a complete list of changes. See repository for full details:
https://bitbucket.org/jpeacock/version (primary)
-0.9921 - 2018-04-##
+0.9921 - 2018-04-11
* Silence overly compulsive GCC 7 warning
https://rt.cpan.org/Ticket/Display.html?id=123477
diff --git a/Makefile.PL b/Makefile.PL
index 3a078b4..bc61e09 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -51,7 +51,7 @@ sub write_makefile
'parent' => 0.221,
);
- WriteMakefile( VERSION => '0.9920',
+ WriteMakefile( VERSION => '0.9921',
NAME => 'version',
LICENSE => 'perl',
MIN_PERL_VERSION=> 5.006002,
diff --git a/README b/README
index 3cdec1c..0074a22 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-version 0.9920
+version 0.9921
==================================
Object oriented versions for all Perl releases from 5.6.2 onward. Replaces
diff --git a/lib/version.pm b/lib/version.pm
index 638f6f7..e4d1fe1 100644
--- a/lib/version.pm
+++ b/lib/version.pm
@@ -10,7 +10,7 @@ if ($] >= 5.015) {
use vars qw(@ISA $VERSION $CLASS $STRICT $LAX *declare *qv);
-$VERSION = 0.9920;
+$VERSION = 0.9921;
$CLASS = 'version';
# !!!!Delete this next block completely when adding to Perl core!!!!
diff --git a/lib/version/regex.pm b/lib/version/regex.pm
index 8c8e0db..77d5451 100644
--- a/lib/version/regex.pm
+++ b/lib/version/regex.pm
@@ -8,7 +8,7 @@ use vars qw(
$LAX_DECIMAL_VERSION $LAX_DOTTED_DECIMAL_VERSION
);
-$VERSION = 0.9920;
+$VERSION = 0.9921;
#--------------------------------------------------------------------------#
# Version regexp components
diff --git a/t/00impl-pp.t b/t/00impl-pp.t
index 9068a5b..027a20e 100644
--- a/t/00impl-pp.t
+++ b/t/00impl-pp.t
@@ -14,7 +14,7 @@ BEGIN {
)
);
require $coretests;
- use_ok('version::vpp', 0.9920);
+ use_ok('version::vpp', 0.9921);
}
BaseTests("version::vpp","new","qv");
diff --git a/t/01base.t b/t/01base.t
index e87e597..608dc52 100644
--- a/t/01base.t
+++ b/t/01base.t
@@ -14,7 +14,7 @@ BEGIN {
)
);
require $coretests;
- use_ok('version', 0.9920);
+ use_ok('version', 0.9921);
}
BaseTests("version","new","qv");
diff --git a/t/02derived.t b/t/02derived.t
index 2de52fa..f3d3ffe 100644
--- a/t/02derived.t
+++ b/t/02derived.t
@@ -15,7 +15,7 @@ BEGIN {
)
);
require $coretests;
- use_ok("version", 0.9920);
+ use_ok("version", 0.9921);
# If we made it this far, we are ok.
}
diff --git a/t/03require.t b/t/03require.t
index 5ec75f1..4146d30 100644
--- a/t/03require.t
+++ b/t/03require.t
@@ -19,7 +19,7 @@ BEGIN {
# Don't want to use, because we need to make sure that the import doesn't
# fire just yet (some code does this to avoid importing qv() and delare()).
require_ok("version");
-is $version::VERSION, 0.9920, "Make sure we have the correct class";
+is $version::VERSION, 0.9921, "Make sure we have the correct class";
ok(!"main"->can("qv"), "We don't have the imported qv()");
ok(!"main"->can("declare"), "We don't have the imported declare()");
diff --git a/t/05sigdie.t b/t/05sigdie.t
index 7724900..c9eecae 100644
--- a/t/05sigdie.t
+++ b/t/05sigdie.t
@@ -14,7 +14,7 @@ BEGIN {
}
BEGIN {
- use version 0.9920;
+ use version 0.9921;
}
pass "Didn't get caught by the wrong DIE handler, which is a good thing";
diff --git a/t/06noop.t b/t/06noop.t
index 4034d99..25f12c6 100644
--- a/t/06noop.t
+++ b/t/06noop.t
@@ -7,7 +7,7 @@
use Test::More qw/no_plan/;
BEGIN {
- use_ok('version', 0.9920);
+ use_ok('version', 0.9921);
}
my $v1 = version->new('1.2');
diff --git a/t/07locale.t b/t/07locale.t
index 99b9b54..8ac74a6 100644
--- a/t/07locale.t
+++ b/t/07locale.t
@@ -11,7 +11,7 @@ use Test::More tests => 8;
use Config;
BEGIN {
- use_ok('version', 0.9920);
+ use_ok('version', 0.9921);
}
SKIP: {
diff --git a/t/08_corelist.t b/t/08_corelist.t
index 2447da7..88a3724 100644
--- a/t/08_corelist.t
+++ b/t/08_corelist.t
@@ -5,7 +5,7 @@
#########################
use Test::More tests => 3;
-use_ok("version", 0.9920);
+use_ok("version", 0.9921);
# do strict lax tests in a sub to isolate a package to test importing
SKIP: {
diff --git a/t/09_list_util.t b/t/09_list_util.t
index 44ab51b..6a42066 100644
--- a/t/09_list_util.t
+++ b/t/09_list_util.t
@@ -4,7 +4,7 @@
#########################
use strict;
-use_ok("version", 0.9920);
+use_ok("version", 0.9921);
use Test::More;
BEGIN {
diff --git a/vperl/vpp.pm b/vperl/vpp.pm
index 84b240e..c95449e 100644
--- a/vperl/vpp.pm
+++ b/vperl/vpp.pm
@@ -123,7 +123,7 @@ use warnings::register;
use Config;
use vars qw($VERSION $CLASS @ISA $LAX $STRICT $WARN_CATEGORY);
-$VERSION = 0.9920;
+$VERSION = 0.9921;
$CLASS = 'version::vpp';
if ($] > 5.015) {
warnings::register_categories(qw/version/);
diff --git a/vutil/lib/version/vxs.pm b/vutil/lib/version/vxs.pm
index c3303c4..8579bbd 100644
--- a/vutil/lib/version/vxs.pm
+++ b/vutil/lib/version/vxs.pm
@@ -5,7 +5,7 @@ use v5.10;
use strict;
use vars qw(@ISA $VERSION $CLASS );
-$VERSION = 0.9920;
+$VERSION = 0.9921;
$CLASS = 'version::vxs';
eval {