summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeon Timmermans <fawaka@gmail.com>2021-04-17 01:36:06 +0200
committerLeon Timmermans <fawaka@gmail.com>2021-04-17 01:36:06 +0200
commiteb9562968d4574a78de1d6834162ce2c57f36e1c (patch)
treed050c1e911da75ba681fcba161c17445769a28c7
parent5f0d97e7acb998d897bcca67c5b32a0492307037 (diff)
Bump to version 0.9929
-rw-r--r--CHANGES4
-rw-r--r--Makefile.PL2
-rw-r--r--README2
-rw-r--r--lib/version.pm2
-rw-r--r--lib/version/regex.pm2
-rw-r--r--t/00impl-pp.t2
-rw-r--r--t/01base.t2
-rw-r--r--t/02derived.t2
-rw-r--r--t/03require.t2
-rw-r--r--t/05sigdie.t2
-rw-r--r--t/06noop.t2
-rw-r--r--t/07locale.t2
-rw-r--r--t/08_corelist.t2
-rw-r--r--t/09_list_util.t2
-rw-r--r--vperl/vpp.pm2
-rw-r--r--vutil/lib/version/vxs.pm2
16 files changed, 19 insertions, 15 deletions
diff --git a/CHANGES b/CHANGES
index c618beb..a8dea21 100644
--- a/CHANGES
+++ b/CHANGES
@@ -4,6 +4,10 @@ This is not a complete list of changes. See repository for full details:
https://github.com/Perl/version.pm
+0.9929
+ * Upgrade to ppport 3.62
+ * Import fix for core build warning
+
0.9928
* silence warning for our LC_NUMERIC_LOCK macro
diff --git a/Makefile.PL b/Makefile.PL
index a3bda83..8450597 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -52,7 +52,7 @@ sub write_makefile
'base' => 0,
);
- WriteMakefile( VERSION => '0.9928',
+ WriteMakefile( VERSION => '0.9929',
NAME => 'version',
LICENSE => 'perl',
MIN_PERL_VERSION=> 5.006002,
diff --git a/README b/README
index c35cb02..289b541 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-version 0.9928
+version 0.9929
==================================
Object oriented versions for all Perl releases from 5.6.2 onward. Replaces
diff --git a/lib/version.pm b/lib/version.pm
index 0d161b0..e05e511 100644
--- a/lib/version.pm
+++ b/lib/version.pm
@@ -8,7 +8,7 @@ if ($] >= 5.015) {
warnings::register_categories(qw/version/);
}
-our $VERSION = 0.9928;
+our $VERSION = 0.9929;
our $CLASS = 'version';
our (@ISA, $STRICT, $LAX);
diff --git a/lib/version/regex.pm b/lib/version/regex.pm
index 3b221be..caaebe6 100644
--- a/lib/version/regex.pm
+++ b/lib/version/regex.pm
@@ -2,7 +2,7 @@ package version::regex;
use strict;
-our $VERSION = 0.9928;
+our $VERSION = 0.9929;
#--------------------------------------------------------------------------#
# Version regexp components
diff --git a/t/00impl-pp.t b/t/00impl-pp.t
index 157491b..2850ba6 100644
--- a/t/00impl-pp.t
+++ b/t/00impl-pp.t
@@ -14,7 +14,7 @@ BEGIN {
)
);
require $coretests;
- use_ok('version::vpp', 0.9928);
+ use_ok('version::vpp', 0.9929);
}
BaseTests("version::vpp","new","qv");
diff --git a/t/01base.t b/t/01base.t
index 65f4aa3..d60abae 100644
--- a/t/01base.t
+++ b/t/01base.t
@@ -14,7 +14,7 @@ BEGIN {
)
);
require $coretests;
- use_ok('version', 0.9928);
+ use_ok('version', 0.9929);
}
BaseTests("version","new","qv");
diff --git a/t/02derived.t b/t/02derived.t
index 4bab2a2..815b592 100644
--- a/t/02derived.t
+++ b/t/02derived.t
@@ -15,7 +15,7 @@ BEGIN {
)
);
require $coretests;
- use_ok("version", 0.9928);
+ use_ok("version", 0.9929);
# If we made it this far, we are ok.
}
diff --git a/t/03require.t b/t/03require.t
index 35efa7b..a7a72ba 100644
--- a/t/03require.t
+++ b/t/03require.t
@@ -19,7 +19,7 @@ BEGIN {
# Don't want to use, because we need to make sure that the import doesn't
# fire just yet (some code does this to avoid importing qv() and delare()).
require_ok("version");
-is $version::VERSION, 0.9928, "Make sure we have the correct class";
+is $version::VERSION, 0.9929, "Make sure we have the correct class";
ok(!"main"->can("qv"), "We don't have the imported qv()");
ok(!"main"->can("declare"), "We don't have the imported declare()");
diff --git a/t/05sigdie.t b/t/05sigdie.t
index 5429731..8d98e5c 100644
--- a/t/05sigdie.t
+++ b/t/05sigdie.t
@@ -14,7 +14,7 @@ BEGIN {
}
BEGIN {
- use version 0.9928;
+ use version 0.9929;
}
pass "Didn't get caught by the wrong DIE handler, which is a good thing";
diff --git a/t/06noop.t b/t/06noop.t
index eb0a45e..b5cf08a 100644
--- a/t/06noop.t
+++ b/t/06noop.t
@@ -7,7 +7,7 @@
use Test::More qw/no_plan/;
BEGIN {
- use_ok('version', 0.9928);
+ use_ok('version', 0.9929);
}
my $v1 = 'version'->new('1.2');
diff --git a/t/07locale.t b/t/07locale.t
index 926850e..eb68d74 100644
--- a/t/07locale.t
+++ b/t/07locale.t
@@ -11,7 +11,7 @@ use Test::More tests => 8;
use Config;
BEGIN {
- use_ok('version', 0.9928);
+ use_ok('version', 0.9929);
}
SKIP: {
diff --git a/t/08_corelist.t b/t/08_corelist.t
index 886b23c..a0b4fdd 100644
--- a/t/08_corelist.t
+++ b/t/08_corelist.t
@@ -5,7 +5,7 @@
#########################
use Test::More tests => 3;
-use_ok("version", 0.9928);
+use_ok("version", 0.9929);
# do strict lax tests in a sub to isolate a package to test importing
SKIP: {
diff --git a/t/09_list_util.t b/t/09_list_util.t
index bcd88a3..cf35407 100644
--- a/t/09_list_util.t
+++ b/t/09_list_util.t
@@ -4,7 +4,7 @@
#########################
use strict;
-use_ok("version", 0.9928);
+use_ok("version", 0.9929);
use Test::More;
BEGIN {
diff --git a/vperl/vpp.pm b/vperl/vpp.pm
index 9c665eb..8368fc0 100644
--- a/vperl/vpp.pm
+++ b/vperl/vpp.pm
@@ -123,7 +123,7 @@ use warnings::register;
use Config;
-our $VERSION = 0.9928;
+our $VERSION = 0.9929;
our $CLASS = 'version::vpp';
our ($LAX, $STRICT, $WARN_CATEGORY);
diff --git a/vutil/lib/version/vxs.pm b/vutil/lib/version/vxs.pm
index 6faff7a..95fc747 100644
--- a/vutil/lib/version/vxs.pm
+++ b/vutil/lib/version/vxs.pm
@@ -4,7 +4,7 @@ package version::vxs;
use v5.10;
use strict;
-our $VERSION = 0.9928;
+our $VERSION = 0.9929;
our $CLASS = 'version::vxs';
our @ISA;