summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgregor herrmann <gregoa@debian.org>2023-08-04 17:43:42 +0200
committergregor herrmann <gregoa@debian.org>2023-08-04 17:43:42 +0200
commit0a61d925a242962a722f287e39ef0bceb06fef77 (patch)
treec1515b8221d57e308fe58dfc99d6786ba523b401
parent17ff2752f7a3ca62f780f05dc01b8cc236f90cb1 (diff)
parent484d4a7697ad04b6f79ce1282e586cef725d5308 (diff)
New upstream version 1.19
-rw-r--r--Changes2
-rw-r--r--Dockerfile2
-rw-r--r--LICENSE6
-rw-r--r--META.json2
-rw-r--r--META.yml2
-rw-r--r--Makefile.PL8
-rw-r--r--README4
-rw-r--r--inc/ZMQ2/SocketWrappers.pm20
-rw-r--r--lib/ZMQ/FFI.pm6
-rw-r--r--lib/ZMQ/FFI/Constants.pm6
-rw-r--r--lib/ZMQ/FFI/ContextRole.pm6
-rw-r--r--lib/ZMQ/FFI/Custom/Raw.pm6
-rw-r--r--lib/ZMQ/FFI/ErrorHelper.pm6
-rw-r--r--lib/ZMQ/FFI/SocketRole.pm6
-rw-r--r--lib/ZMQ/FFI/Util.pm6
-rw-r--r--lib/ZMQ/FFI/Versioner.pm6
-rw-r--r--lib/ZMQ/FFI/ZMQ2/Context.pm8
-rw-r--r--lib/ZMQ/FFI/ZMQ2/Raw.pm6
-rw-r--r--lib/ZMQ/FFI/ZMQ2/Socket.pm28
-rw-r--r--lib/ZMQ/FFI/ZMQ3/Context.pm8
-rw-r--r--lib/ZMQ/FFI/ZMQ3/Raw.pm6
-rw-r--r--lib/ZMQ/FFI/ZMQ3/Socket.pm28
-rw-r--r--lib/ZMQ/FFI/ZMQ4/Context.pm8
-rw-r--r--lib/ZMQ/FFI/ZMQ4/Raw.pm6
-rw-r--r--lib/ZMQ/FFI/ZMQ4/Socket.pm28
-rw-r--r--lib/ZMQ/FFI/ZMQ4_1/Context.pm8
-rw-r--r--lib/ZMQ/FFI/ZMQ4_1/Raw.pm6
-rw-r--r--lib/ZMQ/FFI/ZMQ4_1/Socket.pm28
28 files changed, 132 insertions, 130 deletions
diff --git a/Changes b/Changes
index 32892de..8552d3b 100644
--- a/Changes
+++ b/Changes
@@ -1,4 +1,6 @@
+1.19 2023-08-04 11:16:25+00:00 UTC
+
1.18 2022-03-21 10:48:44+00:00 UTC
- New maintainer @ghenry - welcome and thank you!
diff --git a/Dockerfile b/Dockerfile
index 87472f7..4ea4021 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -79,7 +79,7 @@ RUN apt-get install -y libdist-zilla-perl libterm-ui-perl libanyevent-perl \
FROM dzil-base as zmq-ffi-base
COPY . /zmq-ffi/
RUN cd /zmq-ffi && dzil authordeps --missing | cpanm -v
-RUN cd /zmq-ffi && dzil listdeps --missing | cpanm -v
+RUN cd /zmq-ffi && dzil listdeps --missing | cpanm -v && cpanm -v Sys::SigAction
RUN apt-get -y purge gcc g++ autoconf automake libtool-bin pkg-config \
libssl-dev zlib1g-dev uuid-dev \
&& apt -y autoremove \
diff --git a/LICENSE b/LICENSE
index 34ddb10..93b50f9 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,4 @@
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
@@ -12,7 +12,7 @@ b) the "Artistic License"
--- The GNU General Public License, Version 1, February 1989 ---
-This software is Copyright (c) 2022 by Dylan Cali.
+This software is Copyright (c) 2023 by Dylan Cali.
This is free software, licensed under:
@@ -272,7 +272,7 @@ That's all there is to it!
--- The Artistic License 1.0 ---
-This software is Copyright (c) 2022 by Dylan Cali.
+This software is Copyright (c) 2023 by Dylan Cali.
This is free software, licensed under:
diff --git a/META.json b/META.json
index 3705899..8483593 100644
--- a/META.json
+++ b/META.json
@@ -95,7 +95,7 @@
"web" : "https://github.com/zeromq/perlzmq"
}
},
- "version" : "1.18",
+ "version" : "1.19",
"x_contributors" : [
"Dave Lambley <github@davel.me.uk>",
"Graham Ollis <perl@wdlabs.com>",
diff --git a/META.yml b/META.yml
index 73c2e30..18aaca7 100644
--- a/META.yml
+++ b/META.yml
@@ -58,7 +58,7 @@ requires:
resources:
bugtracker: https://github.com/zeromq/perlzmq/issues
repository: git://github.com/zeromq/perlzmq.git
-version: '1.18'
+version: '1.19'
x_contributors:
- 'Dave Lambley <github@davel.me.uk>'
- 'Graham Ollis <perl@wdlabs.com>'
diff --git a/Makefile.PL b/Makefile.PL
index 166b01e..ae21252 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -5,7 +5,7 @@
use strict;
use warnings;
-# inserted by Dist::Zilla::Plugin::FFI::CheckLib 1.05
+# inserted by Dist::Zilla::Plugin::FFI::CheckLib 1.07
use FFI::CheckLib;
check_lib_or_exit(
alien => 'Alien::ZMQ::latest',
@@ -81,7 +81,7 @@ my %WriteMakefileArgs = (
"locale" => 0,
"utf8" => 0
},
- "VERSION" => "1.18",
+ "VERSION" => "1.19",
"test" => {
"TESTS" => "t/*.t"
}
@@ -124,7 +124,7 @@ my %FallbackPrereqs = (
"warnings" => 0
);
-# inserted by Dist::Zilla::Plugin::DynamicPrereqs 0.039
+# inserted by Dist::Zilla::Plugin::DynamicPrereqs 0.040
if (isnt_os('MSWin32')) {
test_requires('Sys::SigAction', '0')
}
@@ -140,7 +140,7 @@ delete $WriteMakefileArgs{CONFIGURE_REQUIRES}
WriteMakefile(%WriteMakefileArgs);
-# inserted by Dist::Zilla::Plugin::DynamicPrereqs 0.039
+# inserted by Dist::Zilla::Plugin::DynamicPrereqs 0.040
sub _add_prereq {
my ($mm_key, $module, $version_or_range) = @_;
$version_or_range ||= 0;
diff --git a/README b/README
index 440a9f5..4d74ef8 100644
--- a/README
+++ b/README
@@ -1,9 +1,9 @@
This archive contains the distribution ZMQ-FFI,
-version 1.18:
+version 1.19:
version agnostic Perl bindings for zeromq using ffi
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/inc/ZMQ2/SocketWrappers.pm b/inc/ZMQ2/SocketWrappers.pm
index 2feaf7a..e34e6a4 100644
--- a/inc/ZMQ2/SocketWrappers.pm
+++ b/inc/ZMQ2/SocketWrappers.pm
@@ -290,7 +290,7 @@ sub get {
my $optval_len;
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
# ZMQ_IDENTITY uses binary type and can be at most 255 bytes long
#
# ZMQ_LAST_ENDPOINT uses string type and expects a buffer large
@@ -331,7 +331,7 @@ sub get {
}
}
- when ('int') {
+ elsif ($_ eq 'int') {
$optval_len = $self->sockopt_sizes->{'int'};
$self->check_error(
'zmq_getsockopt',
@@ -344,7 +344,7 @@ sub get {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$optval_len = $self->sockopt_sizes->{'sint64'};
$self->check_error(
'zmq_getsockopt',
@@ -357,7 +357,7 @@ sub get {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$optval_len = $self->sockopt_sizes->{'uint64'};
$self->check_error(
'zmq_getsockopt',
@@ -370,7 +370,7 @@ sub get {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -390,7 +390,7 @@ sub set {
[% closed_socket_check %]
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
my ($optval_ptr, $optval_len) = scalar_to_buffer($optval);
$self->check_error(
'zmq_setsockopt',
@@ -403,7 +403,7 @@ sub set {
);
}
- when ('int') {
+ elsif ($_ eq 'int') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int(
@@ -415,7 +415,7 @@ sub set {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int64(
@@ -427,7 +427,7 @@ sub set {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_uint64(
@@ -439,7 +439,7 @@ sub set {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
diff --git a/lib/ZMQ/FFI.pm b/lib/ZMQ/FFI.pm
index f96dffc..d8dc4d4 100644
--- a/lib/ZMQ/FFI.pm
+++ b/lib/ZMQ/FFI.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI;
-$ZMQ::FFI::VERSION = '1.18';
+$ZMQ::FFI::VERSION = '1.19';
# ABSTRACT: version agnostic Perl bindings for zeromq using ffi
use strict;
@@ -65,7 +65,7 @@ ZMQ::FFI - version agnostic Perl bindings for zeromq using ffi
=head1 VERSION
-version 1.18
+version 1.19
=head1 SYNOPSIS
@@ -662,7 +662,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/Constants.pm b/lib/ZMQ/FFI/Constants.pm
index 22c3589..b63d178 100644
--- a/lib/ZMQ/FFI/Constants.pm
+++ b/lib/ZMQ/FFI/Constants.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::Constants;
-$ZMQ::FFI::Constants::VERSION = '1.18';
+$ZMQ::FFI::Constants::VERSION = '1.19';
# ABSTRACT: Generated module of zmq constants. All constants, all versions.
# Generated using ZMQ versions v2.1.0-v4.3.4
@@ -477,7 +477,7 @@ ZMQ::FFI::Constants - Generated module of zmq constants. All constants, all vers
=head1 VERSION
-version 1.18
+version 1.19
=head1 SYNOPSIS
@@ -510,7 +510,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ContextRole.pm b/lib/ZMQ/FFI/ContextRole.pm
index e97c3d5..5f4d970 100644
--- a/lib/ZMQ/FFI/ContextRole.pm
+++ b/lib/ZMQ/FFI/ContextRole.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::ContextRole;
-$ZMQ::FFI::ContextRole::VERSION = '1.18';
+$ZMQ::FFI::ContextRole::VERSION = '1.19';
use Moo::Role;
use ZMQ::FFI::Util qw(current_tid);
@@ -71,7 +71,7 @@ ZMQ::FFI::ContextRole
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -79,7 +79,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/Custom/Raw.pm b/lib/ZMQ/FFI/Custom/Raw.pm
index f4fbf02..bc100fd 100644
--- a/lib/ZMQ/FFI/Custom/Raw.pm
+++ b/lib/ZMQ/FFI/Custom/Raw.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::Custom::Raw;
-$ZMQ::FFI::Custom::Raw::VERSION = '1.18';
+$ZMQ::FFI::Custom::Raw::VERSION = '1.19';
sub load {
my ($soname) = @_;
@@ -69,7 +69,7 @@ ZMQ::FFI::Custom::Raw
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -77,7 +77,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ErrorHelper.pm b/lib/ZMQ/FFI/ErrorHelper.pm
index 843d851..0147ece 100644
--- a/lib/ZMQ/FFI/ErrorHelper.pm
+++ b/lib/ZMQ/FFI/ErrorHelper.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::ErrorHelper;
-$ZMQ::FFI::ErrorHelper::VERSION = '1.18';
+$ZMQ::FFI::ErrorHelper::VERSION = '1.19';
use Carp;
use FFI::Platypus;
use ZMQ::FFI::Util qw(zmq_version);
@@ -110,7 +110,7 @@ ZMQ::FFI::ErrorHelper
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -118,7 +118,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/SocketRole.pm b/lib/ZMQ/FFI/SocketRole.pm
index 52e4362..9c7d71a 100644
--- a/lib/ZMQ/FFI/SocketRole.pm
+++ b/lib/ZMQ/FFI/SocketRole.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::SocketRole;
-$ZMQ::FFI::SocketRole::VERSION = '1.18';
+$ZMQ::FFI::SocketRole::VERSION = '1.19';
use FFI::Platypus;
use FFI::Platypus::Memory qw(malloc);
@@ -143,7 +143,7 @@ ZMQ::FFI::SocketRole
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -151,7 +151,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/Util.pm b/lib/ZMQ/FFI/Util.pm
index 5f024f2..b6f712c 100644
--- a/lib/ZMQ/FFI/Util.pm
+++ b/lib/ZMQ/FFI/Util.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::Util;
-$ZMQ::FFI::Util::VERSION = '1.18';
+$ZMQ::FFI::Util::VERSION = '1.19';
# ABSTRACT: zmq convenience functions
use strict;
@@ -104,7 +104,7 @@ ZMQ::FFI::Util - zmq convenience functions
=head1 VERSION
-version 1.18
+version 1.19
=head1 SYNOPSIS
@@ -147,7 +147,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/Versioner.pm b/lib/ZMQ/FFI/Versioner.pm
index 238725f..f396089 100644
--- a/lib/ZMQ/FFI/Versioner.pm
+++ b/lib/ZMQ/FFI/Versioner.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::Versioner;
-$ZMQ::FFI::Versioner::VERSION = '1.18';
+$ZMQ::FFI::Versioner::VERSION = '1.19';
use Moo::Role;
use ZMQ::FFI::Util qw(zmq_version);
@@ -34,7 +34,7 @@ ZMQ::FFI::Versioner
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -42,7 +42,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ2/Context.pm b/lib/ZMQ/FFI/ZMQ2/Context.pm
index 660de9e..5ea1fb9 100644
--- a/lib/ZMQ/FFI/ZMQ2/Context.pm
+++ b/lib/ZMQ/FFI/ZMQ2/Context.pm
@@ -1,9 +1,9 @@
#
-# Module Generated by Template::Tiny on Mon Mar 21 10:48:46 UTC 2022
+# Module Generated by Template::Tiny on Fri Aug 4 11:16:27 UTC 2023
#
package ZMQ::FFI::ZMQ2::Context;
-$ZMQ::FFI::ZMQ2::Context::VERSION = '1.18';
+$ZMQ::FFI::ZMQ2::Context::VERSION = '1.19';
use FFI::Platypus;
use ZMQ::FFI::Util qw(zmq_soname current_tid);
use ZMQ::FFI::Constants qw(:all);
@@ -228,7 +228,7 @@ ZMQ::FFI::ZMQ2::Context
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -236,7 +236,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ2/Raw.pm b/lib/ZMQ/FFI/ZMQ2/Raw.pm
index 30f02ce..81d4bf6 100644
--- a/lib/ZMQ/FFI/ZMQ2/Raw.pm
+++ b/lib/ZMQ/FFI/ZMQ2/Raw.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::ZMQ2::Raw;
-$ZMQ::FFI::ZMQ2::Raw::VERSION = '1.18';
+$ZMQ::FFI::ZMQ2::Raw::VERSION = '1.19';
use FFI::Platypus;
sub load {
@@ -119,7 +119,7 @@ ZMQ::FFI::ZMQ2::Raw
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -127,7 +127,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ2/Socket.pm b/lib/ZMQ/FFI/ZMQ2/Socket.pm
index b6a8d62..1ce820f 100644
--- a/lib/ZMQ/FFI/ZMQ2/Socket.pm
+++ b/lib/ZMQ/FFI/ZMQ2/Socket.pm
@@ -1,9 +1,9 @@
#
-# Module Generated by Template::Tiny on Mon Mar 21 10:48:46 UTC 2022
+# Module Generated by Template::Tiny on Fri Aug 4 11:16:27 UTC 2023
#
package ZMQ::FFI::ZMQ2::Socket;
-$ZMQ::FFI::ZMQ2::Socket::VERSION = '1.18';
+$ZMQ::FFI::ZMQ2::Socket::VERSION = '1.19';
use FFI::Platypus;
use FFI::Platypus::Buffer;
use FFI::Platypus::Memory qw(malloc free memcpy);
@@ -350,7 +350,7 @@ sub get {
my $optval_len;
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
# ZMQ_IDENTITY uses binary type and can be at most 255 bytes long
#
# ZMQ_LAST_ENDPOINT uses string type and expects a buffer large
@@ -391,7 +391,7 @@ sub get {
}
}
- when ('int') {
+ elsif ($_ eq 'int') {
$optval_len = $self->sockopt_sizes->{'int'};
$self->check_error(
'zmq_getsockopt',
@@ -404,7 +404,7 @@ sub get {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$optval_len = $self->sockopt_sizes->{'sint64'};
$self->check_error(
'zmq_getsockopt',
@@ -417,7 +417,7 @@ sub get {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$optval_len = $self->sockopt_sizes->{'uint64'};
$self->check_error(
'zmq_getsockopt',
@@ -430,7 +430,7 @@ sub get {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -451,7 +451,7 @@ sub set {
}
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
my ($optval_ptr, $optval_len) = scalar_to_buffer($optval);
$self->check_error(
'zmq_setsockopt',
@@ -464,7 +464,7 @@ sub set {
);
}
- when ('int') {
+ elsif ($_ eq 'int') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int(
@@ -476,7 +476,7 @@ sub set {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int64(
@@ -488,7 +488,7 @@ sub set {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_uint64(
@@ -500,7 +500,7 @@ sub set {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -591,7 +591,7 @@ ZMQ::FFI::ZMQ2::Socket
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -599,7 +599,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ3/Context.pm b/lib/ZMQ/FFI/ZMQ3/Context.pm
index 1a00775..2b62d22 100644
--- a/lib/ZMQ/FFI/ZMQ3/Context.pm
+++ b/lib/ZMQ/FFI/ZMQ3/Context.pm
@@ -1,9 +1,9 @@
#
-# Module Generated by Template::Tiny on Mon Mar 21 10:48:46 UTC 2022
+# Module Generated by Template::Tiny on Fri Aug 4 11:16:27 UTC 2023
#
package ZMQ::FFI::ZMQ3::Context;
-$ZMQ::FFI::ZMQ3::Context::VERSION = '1.18';
+$ZMQ::FFI::ZMQ3::Context::VERSION = '1.19';
use FFI::Platypus;
use ZMQ::FFI::Util qw(zmq_soname current_tid);
use ZMQ::FFI::Constants qw(:all);
@@ -221,7 +221,7 @@ ZMQ::FFI::ZMQ3::Context
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -229,7 +229,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ3/Raw.pm b/lib/ZMQ/FFI/ZMQ3/Raw.pm
index fe62d4d..ff07a63 100644
--- a/lib/ZMQ/FFI/ZMQ3/Raw.pm
+++ b/lib/ZMQ/FFI/ZMQ3/Raw.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::ZMQ3::Raw;
-$ZMQ::FFI::ZMQ3::Raw::VERSION = '1.18';
+$ZMQ::FFI::ZMQ3::Raw::VERSION = '1.19';
use FFI::Platypus;
sub load {
@@ -149,7 +149,7 @@ ZMQ::FFI::ZMQ3::Raw
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -157,7 +157,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ3/Socket.pm b/lib/ZMQ/FFI/ZMQ3/Socket.pm
index 9714d3f..cd8d31b 100644
--- a/lib/ZMQ/FFI/ZMQ3/Socket.pm
+++ b/lib/ZMQ/FFI/ZMQ3/Socket.pm
@@ -1,9 +1,9 @@
#
-# Module Generated by Template::Tiny on Mon Mar 21 10:48:46 UTC 2022
+# Module Generated by Template::Tiny on Fri Aug 4 11:16:27 UTC 2023
#
package ZMQ::FFI::ZMQ3::Socket;
-$ZMQ::FFI::ZMQ3::Socket::VERSION = '1.18';
+$ZMQ::FFI::ZMQ3::Socket::VERSION = '1.19';
use FFI::Platypus;
use FFI::Platypus::Buffer;
use FFI::Platypus::Memory qw(malloc free memcpy);
@@ -342,7 +342,7 @@ sub get {
my $optval_len;
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
# ZMQ_IDENTITY uses binary type and can be at most 255 bytes long
#
# ZMQ_LAST_ENDPOINT uses string type and expects a buffer large
@@ -383,7 +383,7 @@ sub get {
}
}
- when ('int') {
+ elsif ($_ eq 'int') {
$optval_len = $self->sockopt_sizes->{'int'};
$self->check_error(
'zmq_getsockopt',
@@ -396,7 +396,7 @@ sub get {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$optval_len = $self->sockopt_sizes->{'sint64'};
$self->check_error(
'zmq_getsockopt',
@@ -409,7 +409,7 @@ sub get {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$optval_len = $self->sockopt_sizes->{'uint64'};
$self->check_error(
'zmq_getsockopt',
@@ -422,7 +422,7 @@ sub get {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -443,7 +443,7 @@ sub set {
}
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
my ($optval_ptr, $optval_len) = scalar_to_buffer($optval);
$self->check_error(
'zmq_setsockopt',
@@ -456,7 +456,7 @@ sub set {
);
}
- when ('int') {
+ elsif ($_ eq 'int') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int(
@@ -468,7 +468,7 @@ sub set {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int64(
@@ -480,7 +480,7 @@ sub set {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_uint64(
@@ -492,7 +492,7 @@ sub set {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -597,7 +597,7 @@ ZMQ::FFI::ZMQ3::Socket
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -605,7 +605,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ4/Context.pm b/lib/ZMQ/FFI/ZMQ4/Context.pm
index 53c8936..118ba6f 100644
--- a/lib/ZMQ/FFI/ZMQ4/Context.pm
+++ b/lib/ZMQ/FFI/ZMQ4/Context.pm
@@ -1,9 +1,9 @@
#
-# Module Generated by Template::Tiny on Mon Mar 21 10:48:46 UTC 2022
+# Module Generated by Template::Tiny on Fri Aug 4 11:16:27 UTC 2023
#
package ZMQ::FFI::ZMQ4::Context;
-$ZMQ::FFI::ZMQ4::Context::VERSION = '1.18';
+$ZMQ::FFI::ZMQ4::Context::VERSION = '1.19';
use FFI::Platypus;
use ZMQ::FFI::Util qw(zmq_soname current_tid);
use ZMQ::FFI::Constants qw(:all);
@@ -253,7 +253,7 @@ ZMQ::FFI::ZMQ4::Context
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -261,7 +261,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ4/Raw.pm b/lib/ZMQ/FFI/ZMQ4/Raw.pm
index f287b12..b090588 100644
--- a/lib/ZMQ/FFI/ZMQ4/Raw.pm
+++ b/lib/ZMQ/FFI/ZMQ4/Raw.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::ZMQ4::Raw;
-$ZMQ::FFI::ZMQ4::Raw::VERSION = '1.18';
+$ZMQ::FFI::ZMQ4::Raw::VERSION = '1.19';
use FFI::Platypus;
sub load {
@@ -167,7 +167,7 @@ ZMQ::FFI::ZMQ4::Raw
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -175,7 +175,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ4/Socket.pm b/lib/ZMQ/FFI/ZMQ4/Socket.pm
index adffba2..2e4dbd4 100644
--- a/lib/ZMQ/FFI/ZMQ4/Socket.pm
+++ b/lib/ZMQ/FFI/ZMQ4/Socket.pm
@@ -1,9 +1,9 @@
#
-# Module Generated by Template::Tiny on Mon Mar 21 10:48:46 UTC 2022
+# Module Generated by Template::Tiny on Fri Aug 4 11:16:27 UTC 2023
#
package ZMQ::FFI::ZMQ4::Socket;
-$ZMQ::FFI::ZMQ4::Socket::VERSION = '1.18';
+$ZMQ::FFI::ZMQ4::Socket::VERSION = '1.19';
use FFI::Platypus;
use FFI::Platypus::Buffer;
use FFI::Platypus::Memory qw(malloc free memcpy);
@@ -342,7 +342,7 @@ sub get {
my $optval_len;
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
# ZMQ_IDENTITY uses binary type and can be at most 255 bytes long
#
# ZMQ_LAST_ENDPOINT uses string type and expects a buffer large
@@ -383,7 +383,7 @@ sub get {
}
}
- when ('int') {
+ elsif ($_ eq 'int') {
$optval_len = $self->sockopt_sizes->{'int'};
$self->check_error(
'zmq_getsockopt',
@@ -396,7 +396,7 @@ sub get {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$optval_len = $self->sockopt_sizes->{'sint64'};
$self->check_error(
'zmq_getsockopt',
@@ -409,7 +409,7 @@ sub get {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$optval_len = $self->sockopt_sizes->{'uint64'};
$self->check_error(
'zmq_getsockopt',
@@ -422,7 +422,7 @@ sub get {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -443,7 +443,7 @@ sub set {
}
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
my ($optval_ptr, $optval_len) = scalar_to_buffer($optval);
$self->check_error(
'zmq_setsockopt',
@@ -456,7 +456,7 @@ sub set {
);
}
- when ('int') {
+ elsif ($_ eq 'int') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int(
@@ -468,7 +468,7 @@ sub set {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int64(
@@ -480,7 +480,7 @@ sub set {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_uint64(
@@ -492,7 +492,7 @@ sub set {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -588,7 +588,7 @@ ZMQ::FFI::ZMQ4::Socket
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -596,7 +596,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ4_1/Context.pm b/lib/ZMQ/FFI/ZMQ4_1/Context.pm
index b635eda..fbf619b 100644
--- a/lib/ZMQ/FFI/ZMQ4_1/Context.pm
+++ b/lib/ZMQ/FFI/ZMQ4_1/Context.pm
@@ -1,9 +1,9 @@
#
-# Module Generated by Template::Tiny on Mon Mar 21 10:48:46 UTC 2022
+# Module Generated by Template::Tiny on Fri Aug 4 11:16:27 UTC 2023
#
package ZMQ::FFI::ZMQ4_1::Context;
-$ZMQ::FFI::ZMQ4_1::Context::VERSION = '1.18';
+$ZMQ::FFI::ZMQ4_1::Context::VERSION = '1.19';
use FFI::Platypus;
use ZMQ::FFI::Util qw(zmq_soname current_tid);
use ZMQ::FFI::Constants qw(:all);
@@ -250,7 +250,7 @@ ZMQ::FFI::ZMQ4_1::Context
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -258,7 +258,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ4_1/Raw.pm b/lib/ZMQ/FFI/ZMQ4_1/Raw.pm
index c6b5b91..7ebed69 100644
--- a/lib/ZMQ/FFI/ZMQ4_1/Raw.pm
+++ b/lib/ZMQ/FFI/ZMQ4_1/Raw.pm
@@ -1,5 +1,5 @@
package ZMQ::FFI::ZMQ4_1::Raw;
-$ZMQ::FFI::ZMQ4_1::Raw::VERSION = '1.18';
+$ZMQ::FFI::ZMQ4_1::Raw::VERSION = '1.19';
use FFI::Platypus;
sub load {
@@ -173,7 +173,7 @@ ZMQ::FFI::ZMQ4_1::Raw
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -181,7 +181,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.
diff --git a/lib/ZMQ/FFI/ZMQ4_1/Socket.pm b/lib/ZMQ/FFI/ZMQ4_1/Socket.pm
index 9c3499d..5d05a34 100644
--- a/lib/ZMQ/FFI/ZMQ4_1/Socket.pm
+++ b/lib/ZMQ/FFI/ZMQ4_1/Socket.pm
@@ -1,9 +1,9 @@
#
-# Module Generated by Template::Tiny on Mon Mar 21 10:48:46 UTC 2022
+# Module Generated by Template::Tiny on Fri Aug 4 11:16:27 UTC 2023
#
package ZMQ::FFI::ZMQ4_1::Socket;
-$ZMQ::FFI::ZMQ4_1::Socket::VERSION = '1.18';
+$ZMQ::FFI::ZMQ4_1::Socket::VERSION = '1.19';
use FFI::Platypus;
use FFI::Platypus::Buffer;
use FFI::Platypus::Memory qw(malloc free memcpy);
@@ -342,7 +342,7 @@ sub get {
my $optval_len;
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
# ZMQ_IDENTITY uses binary type and can be at most 255 bytes long
#
# ZMQ_LAST_ENDPOINT uses string type and expects a buffer large
@@ -383,7 +383,7 @@ sub get {
}
}
- when ('int') {
+ elsif ($_ eq 'int') {
$optval_len = $self->sockopt_sizes->{'int'};
$self->check_error(
'zmq_getsockopt',
@@ -396,7 +396,7 @@ sub get {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$optval_len = $self->sockopt_sizes->{'sint64'};
$self->check_error(
'zmq_getsockopt',
@@ -409,7 +409,7 @@ sub get {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$optval_len = $self->sockopt_sizes->{'uint64'};
$self->check_error(
'zmq_getsockopt',
@@ -422,7 +422,7 @@ sub get {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -443,7 +443,7 @@ sub set {
}
for ($opt_type) {
- when (/^(binary|string)$/) {
+ if ($_ =~ /^(binary|string)$/) {
my ($optval_ptr, $optval_len) = scalar_to_buffer($optval);
$self->check_error(
'zmq_setsockopt',
@@ -456,7 +456,7 @@ sub set {
);
}
- when ('int') {
+ elsif ($_ eq 'int') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int(
@@ -468,7 +468,7 @@ sub set {
);
}
- when ('int64_t') {
+ elsif ($_ eq 'int64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_int64(
@@ -480,7 +480,7 @@ sub set {
);
}
- when ('uint64_t') {
+ elsif ($_ eq 'uint64_t') {
$self->check_error(
'zmq_setsockopt',
zmq_setsockopt_uint64(
@@ -492,7 +492,7 @@ sub set {
);
}
- default {
+ else {
croak "unknown type $opt_type";
}
}
@@ -588,7 +588,7 @@ ZMQ::FFI::ZMQ4_1::Socket
=head1 VERSION
-version 1.18
+version 1.19
=head1 AUTHOR
@@ -596,7 +596,7 @@ Dylan Cali <calid1984@gmail.com>
=head1 COPYRIGHT AND LICENSE
-This software is copyright (c) 2022 by Dylan Cali.
+This software is copyright (c) 2023 by Dylan Cali.
This is free software; you can redistribute it and/or modify it under
the same terms as the Perl 5 programming language system itself.