summaryrefslogtreecommitdiff
path: root/doc/installation.rst
diff options
context:
space:
mode:
Diffstat (limited to 'doc/installation.rst')
-rw-r--r--doc/installation.rst51
1 files changed, 29 insertions, 22 deletions
diff --git a/doc/installation.rst b/doc/installation.rst
index 61e488e..99d776a 100644
--- a/doc/installation.rst
+++ b/doc/installation.rst
@@ -3,24 +3,31 @@ Downloading and Installation
====================================
.. _lmfit github repository: http://github.com/lmfit/lmfit-py
-.. _Python Setup Tools: http://pypi.python.org/pypi/setuptools
-.. _pip: https://pip.pypa.io/
-.. _nose: http://nose.readthedocs.org/
+.. _python: http://python.org
+.. _scipy: http://scipy.org/scipylib/index.html
+.. _numpy: http://numpy.org/
+.. _nose: http://nose.readthedocs.org/
+.. _pytest: http://pytest.org/
+.. _emcee: http://dan.iel.fm/emcee/
+.. _pandas: http://pandas.pydata.org/
+.. _jupyter: http://jupyter.org/
+.. _matplotlib: http://matplotlib.org/
Prerequisites
~~~~~~~~~~~~~~~
-The lmfit package requires Python, Numpy, and Scipy.
+The lmfit package requires `Python`_, `NumPy`_, and `SciPy`_.
-Lmfit works with Python 2.7, 3.3, 3.4, and 3.5. Support for Python 2.6
-ended with Lmfit version 0.9.4. Scipy version 0.14 or higher is required,
+Lmfit works with Python versions 2.7, 3.3, 3.4, 3.5, and 3.6. Support for Python 2.6
+ended with lmfit version 0.9.4. Scipy version 0.15 or higher is required,
with 0.17 or higher recommended to be able to use the latest optimization
-features from scipy. Numpy version 1.5 or higher is required.
+features. NumPy version 1.5.1 or higher is required.
-In order to run the test suite, the `nose`_ framework is required. Some
-parts of lmfit will be able to make use of IPython (version 4 or higher),
-matplotlib, and pandas if those libraries are installed, but no core
-functionality of lmfit requires these.
+In order to run the test suite, either the `nose`_ or `pytest`_ package is
+required. Some functionality of lmfit requires the `emcee`_ package, some
+functionality will make use of the `pandas`_, `Jupyter`_ or `matplotlib`_
+packages if available. We highly recommend each of these
+packages.
Downloads
@@ -32,20 +39,18 @@ The latest stable version of lmfit is |release| is available from `PyPi
Installation
~~~~~~~~~~~~~~~~~
-If you have `pip`_ installed, you can install lmfit with::
+With ``pip`` now widely avaliable, you can install lmfit with::
pip install lmfit
-or you can download the source kit, unpack it and install with::
+Alternatively, you can download the source kit, unpack it and install with::
python setup.py install
-For Anaconda Python, lmfit is not an official packages, but several
+For Anaconda Python, lmfit is not an official package, but several
Anaconda channels provide it, allowing installation with (for example)::
conda install -c conda-forge lmfit
- conda install -c newville lmfit
-
Development Version
~~~~~~~~~~~~~~~~~~~~~~~~
@@ -62,14 +67,16 @@ and install using::
Testing
~~~~~~~~~~
-A battery of tests scripts that can be run with the `nose`_ testing
-framework is distributed with lmfit in the ``tests`` folder. These are
-routinely run on the development version. Running ``nosetests`` should run
-all of these tests to completion without errors or failures.
+A battery of tests scripts that can be run with either the `nose`_ or
+`pytest`_ testing framework is distributed with lmfit in the ``tests``
+folder. These are automatically run as part of the development process.
+For any release or any master branch from the git repository, running
+``pytest`` or ``nosetests`` should run all of these tests to completion
+without errors or failures.
Many of the examples in this documentation are distributed with lmfit in
-the ``examples`` folder, and should also run for you. Many of these require
-
+the ``examples`` folder, and should also run for you. Some of these
+examples assume `matplotlib`_ has been installed and is working correctly.
Acknowledgements
~~~~~~~~~~~~~~~~~~