summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2016-11-25 15:43:14 +0100
committerDidier Raboud <odyx@debian.org>2016-11-25 15:43:14 +0100
commit88f7c8db56684b9d40a247237f703701885933ff (patch)
treee25a15e4e4cab94e4f1eebbc56a85586b31d7a8f /debian
parent808ac018d8f4e61fba453a48ea50f72675528736 (diff)
Also run the tests for all pyversions (Python 2.7 only)
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 7e803de..690f84c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,7 @@
derives_from_ubuntu := $(shell (dpkg-vendor --derives-from Ubuntu && echo "yes") || echo "no")
+PY2VERSIONS=$(shell [ -x /usr/bin/pyversions ] && pyversions -vr)
PY3VERSIONS=$(shell [ -x /usr/bin/py3versions ] && py3versions -vr)
%:
@@ -52,7 +53,7 @@ override_dh_clean:
ifneq ($(filter nocheck,$(DEB_BUILD_OPTIONS)),)
override_dh_auto_test:
else
-override_dh_auto_test: $(PY3VERSIONS:%=test-python%)
+override_dh_auto_test: $(PY3VERSIONS:%=test-python%) $(PY2VERSIONS:%=test-python%)
endif
test-python%: