summaryrefslogtreecommitdiff
path: root/test
diff options
context:
space:
mode:
authorDidier Raboud <odyx@debian.org>2016-11-25 15:39:38 +0100
committerDidier Raboud <odyx@debian.org>2016-11-25 15:39:38 +0100
commit808ac018d8f4e61fba453a48ea50f72675528736 (patch)
tree85a0b9bd75a977ad6395c21cceaf6d4586224de0 /test
parent9abd510ad3aba43ab4a2c0a158031ce5b093cb91 (diff)
Test the distro-info non-Debian fallback, to fix #845489
Diffstat (limited to 'test')
-rw-r--r--test/test_lsb_release.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/test/test_lsb_release.py b/test/test_lsb_release.py
index 936af90..082bea3 100644
--- a/test/test_lsb_release.py
+++ b/test/test_lsb_release.py
@@ -288,6 +288,13 @@ class TestLSBRelease(unittest.TestCase):
self.assertEqual(lr.get_lsb_information(),supposed_output)
os.environ.pop('LSB_ETC_LSB_RELEASE')
+ def test_get_distro_information_no_distinfo_file(self):
+ # Test that a missing /usr/share/distro-info/{distro}.csv indeed falls
+ # back on Debian's information
+ debian_info = lr.get_distro_info()
+ other_distro_info = lr.get_distro_info(origin='x-not-debian')
+ self.assertEqual(debian_info, other_distro_info)
+
def test_get_distro_information(self):
# Test that an inexistant /etc/lsb-release leads to empty output
supposed_output = get_arch_distinfo()