summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rwxr-xr-xdebian/rules1
-rw-r--r--test/test_initdutils.py31
2 files changed, 32 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 07c6067..590258d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -50,6 +50,7 @@ override_dh_auto_test: $(PY2VERSIONS:%=test-python%)
test-python%:
PYTHONPATH=. python$* test/test_lsb_release.py -vv
+ PYTHONPATH=. python$* test/test_initdutils.py -vv
override_dh_python2:
dh_python2
diff --git a/test/test_initdutils.py b/test/test_initdutils.py
new file mode 100644
index 0000000..b422a68
--- /dev/null
+++ b/test/test_initdutils.py
@@ -0,0 +1,31 @@
+#!/usr/bin/python
+import unittest
+
+import initdutils as iu
+
+class TestInitdUtilse(unittest.TestCase):
+
+ @unittest.skip('Test not implemented.')
+ def test_scan_initfile():
+ raise NotImplementedError()
+ @unittest.skip('Test not implemented.')
+ def test_save_facilities():
+ raise NotImplementedError()
+ @unittest.skip('Test not implemented.')
+ def test_load_facilities():
+ raise NotImplementedError()
+ @unittest.skip('Test not implemented.')
+ def test_load_depends():
+ raise NotImplementedError()
+ @unittest.skip('Test not implemented.')
+ def test_save_depends():
+ raise NotImplementedError()
+ @unittest.skip('Test not implemented.')
+ def test_load_lsbinstall_info():
+ raise NotImplementedError()
+ @unittest.skip('Test not implemented.')
+ def test_save_lsbinstall_info():
+ raise NotImplementedError()
+
+if __name__ == '__main__':
+ unittest.main()