summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSean Whitton <spwhitton@spwhitton.name>2018-12-28 07:41:34 +0000
committerSean Whitton <spwhitton@spwhitton.name>2018-12-28 07:41:34 +0000
commitc4fe748537f6dbb3b37affe8cbec35a8c88bea8f (patch)
tree477b9a862041721aa09b4ba2049275d21144ab80
parent5b7a0c9ef0dc3c08b42aaeabcae42f9ff3a12f92 (diff)
parent21cb2927d672cc6bf631d8373a361b1766ccf004 (diff)
Merge tag 'v1.7.1'
Version 1.7.1 # gpg: Signature made Tue 20 Nov 2018 02:27:21 GMT # gpg: using RSA key B1457DB5DC33963799B314FE52132872E933231E # gpg: Can't check signature: No public key
-rw-r--r--.travis.yml7
-rw-r--r--Makefile3
-rw-r--r--NEWS5
-rw-r--r--magit-annex.el38
4 files changed, 33 insertions, 20 deletions
diff --git a/.travis.yml b/.travis.yml
index 6f0ddc6..a17060a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,3 +1,4 @@
+sudo: false
language: generic
env:
global:
@@ -13,6 +14,7 @@ install:
- $CURL -O https://downloads.kitenet.net/git-annex/linux/current/git-annex-standalone-amd64.tar.gz
- tar -xaf git-annex-standalone-amd64.tar.gz
- export PATH="$PWD/git-annex.linux${PATH:+:}$PATH"
+ - export LOCPATH=
- $CURL -O https://github.com/npostavs/emacs-travis/releases/download/bins/emacs-bin-${EMACS_VERSION}.tar.gz
- tar -xaf emacs-bin-${EMACS_VERSION}.tar.gz -C /
- export EMACS=/tmp/emacs/bin/emacs
@@ -20,9 +22,12 @@ install:
- cd magit
- $CURL -O ${GHRAW}/magnars/dash.el/master/dash.el
- $CURL -O ${GHRAW}/magit/ghub/master/ghub.el
+ - $CURL -O ${GHRAW}/magit/ghub/master/ghub-graphql.el
+ - $CURL -O ${GHRAW}/vermiculus/graphql.el/master/graphql.el
- $CURL -O ${GHRAW}/magit/magit-popup/master/magit-popup.el
+ - $CURL -O ${GHRAW}/volrath/treepy.el/master/treepy.el
- $CURL -O ${GHRAW}/magit/with-editor/master/with-editor.el
- - $EMACS -Q --batch -L . -f batch-byte-compile dash.el ghub.el magit-popup.el with-editor.el
+ - $EMACS -Q --batch -L . -f batch-byte-compile dash.el ghub.el ghub-graphql.el graphql.el magit-popup.el treepy.el with-editor.el
- make lisp EMACSBIN=$EMACS DASH_DIR=$PWD
- cd ..
- git annex version
diff --git a/Makefile b/Makefile
index 172f538..0244e0b 100644
--- a/Makefile
+++ b/Makefile
@@ -4,11 +4,14 @@
MAGIT_DIR ?= /dev/null
MAGIT_POPUP_DIR ?= /dev/null
GHUB_DIR ?= /dev/null
+GRAPHQL_DIR ?= /dev/null
+TREEPY_DIR ?= /dev/null
DASH_DIR ?= /dev/null
WITH_EDITOR_DIR ?= /dev/null
EMACSBIN ?= emacs
LOAD_PATH = -L $(DASH_DIR) -L $(WITH_EDITOR_DIR) -L $(GHUB_DIR) \
+ -L $(GRAPHQL_DIR) -L $(TREEPY_DIR) \
-L $(MAGIT_POPUP_DIR) -L $(MAGIT_DIR)
BATCH = $(EMACSBIN) -Q --batch $(LOAD_PATH)
diff --git a/NEWS b/NEWS
index 75cdfbb..ced84d6 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,10 @@
Magit-annex NEWS -- history of user-visible changes -*- mode: org; -*-
+* 1.7.0
+
+Magit-annex has been updated for the latest version of Magit and now
+requires version 2.90.0 or later.
+
* 1.6.0
** New features
diff --git a/magit-annex.el b/magit-annex.el
index 2348ad4..cdb8aef 100644
--- a/magit-annex.el
+++ b/magit-annex.el
@@ -6,8 +6,8 @@
;; RĂ©mi Vanicat <vanicat@debian.org>
;; URL: https://github.com/magit/magit-annex
;; Keywords: vc tools
-;; Version: 1.6.0
-;; Package-Requires: ((cl-lib "0.3") (magit "2.12.0"))
+;; Version: 1.7.1
+;; Package-Requires: ((cl-lib "0.3") (magit "2.90.0"))
;; This program is free software; you can redistribute it and/or modify
;; it under the terms of the GNU General Public License as published by
@@ -98,15 +98,15 @@
"Whether to confirm before adding all changes to the annex."
:type 'boolean)
+(define-obsolete-variable-alias 'magit-annex-standard-options
+ 'magit-annex-global-arguments "1.4.0")
+
(defcustom magit-annex-global-arguments nil
"Arguments that are added to every git-annex call.
These are placed after \"annex\" in the call, whereas values from
`magit-git-global-arguments' are placed after \"git\"."
:type '(repeat string))
-(define-obsolete-variable-alias 'magit-annex-standard-options
- 'magit-annex-global-arguments "1.4.0")
-
(defcustom magit-annex-limit-file-choices t
"Limit choices for file commands based on state of repo.
For example, if locking a file, limit choices to unlocked files."
@@ -231,9 +231,11 @@ program used to open the unused file."
;;;###autoload
(eval-after-load 'magit
'(progn
- (define-key magit-mode-map "@" 'magit-annex-popup-or-init)
- (magit-define-popup-action 'magit-dispatch-popup
- ?@ "Annex" 'magit-annex-popup-or-init ?!)))
+ (require 'magit-popup)
+ (when (boundp 'magit-dispatch-popup)
+ (define-key magit-mode-map "@" 'magit-annex-popup-or-init)
+ (magit-define-popup-action 'magit-dispatch-popup
+ ?@ "Annex" 'magit-annex-popup-or-init ?!))))
@@ -412,18 +414,17 @@ With a prefix argument, prompt for FILE.
(capitalize command) command)
(interactive
(list
- (let ((default
- (--when-let
- (or (mapcar #'cdr (magit-region-values 'annex-list-file))
- (-some-> (cdr (magit-section-when annex-list-file))
- (list))
- (and (derived-mode-p 'dired-mode)
- (dired-get-marked-files t)))
- (mapconcat #'identity it ","))))
+ (let* ((files (or (mapcar #'cdr (magit-region-values 'annex-list-file))
+ (when-let ((file (cdr (magit-section-value-if
+ 'annex-list-file))))
+ (list file))
+ (and (derived-mode-p 'dired-mode)
+ (dired-get-marked-files t))))
+ (default (mapconcat #'identity files ",")))
(magit-annex-read-files
(concat ,(capitalize command)
" file,s"
- (and default (format " (%s)" default))
+ (and files (format " (%s)" default))
": ")
,limit
default))
@@ -530,8 +531,7 @@ value for the '-S' flag. The '--stat' flag is also enabled if
(magit-invoke-popup 'magit-log-popup nil nil)))))
(defun magit-annex--file-name-from-key (key)
- (magit-git-string "annex" "examinekey" key
- "--format=.git/annex/objects/${hashdirmixed}${key}/${key}"))
+ (magit-git-string "annex" "contentlocation" key))
(declare-function dired-read-shell-command "dired-aux" (prompt arg files))