summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThadeu Lima de Souza Cascardo <cascardo@debian.org>2020-03-03 05:21:41 -0300
committerThadeu Lima de Souza Cascardo <cascardo@debian.org>2020-03-03 05:21:41 -0300
commit959caaff3017a53a8b8fcdc3d21ecdf2fcc4d3b5 (patch)
tree0b02c2c969393ddd0f923be05d4b3c3db453701f
parent38a7883d4304764f4ed96ef34d76ea7a632a60e0 (diff)
Commit patch queue (exported by git-debrebase)debian/1%1.6.7-1archive/debian/1%1.6.7-1
[git-debrebase make-patches: export and commit patches]
-rw-r--r--debian/patches/0002-adapt-makefile-to-debian.patch45
-rw-r--r--debian/patches/series1
2 files changed, 46 insertions, 0 deletions
diff --git a/debian/patches/0002-adapt-makefile-to-debian.patch b/debian/patches/0002-adapt-makefile-to-debian.patch
new file mode 100644
index 0000000..556a205
--- /dev/null
+++ b/debian/patches/0002-adapt-makefile-to-debian.patch
@@ -0,0 +1,45 @@
+From: Louis Bouchard <louis.bouchard@ubuntu.com>
+Date: Mon, 17 Dec 2018 15:21:09 -0200
+Subject: adapt-makefile-to-debian
+
+===================================================================
+---
+ Makefile | 18 +++++-------------
+ 1 file changed, 5 insertions(+), 13 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 388faf7..90d55d9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -95,26 +95,18 @@ $(OBJ_ARCH): $(SRC_ARCH)
+
+ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJ_PART) $(OBJ_ARCH) -rdynamic -o $@ $< $(LIBS)
+- echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8
+- grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8
+- mv temp.8 makedumpfile.8
+- gzip -c ./makedumpfile.8 > ./makedumpfile.8.gz
+- echo .TH MAKEDUMPFILE.CONF 5 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.5
+- grep -v "^.TH MAKEDUMPFILE.CONF 5" $(VPATH)makedumpfile.conf.5 >> temp.5
+- mv temp.5 makedumpfile.conf.5
+- gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz
+
+ eppic_makedumpfile.so: extension_eppic.c
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -rdynamic -o $@ extension_eppic.c -fPIC -leppic -ltinfo
+
+ clean:
+- rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz makedumpfile.conf.5.gz
++ rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile
+
+ install:
+- install -m 755 -d ${DESTDIR}/usr/sbin ${DESTDIR}/usr/share/man/man5 ${DESTDIR}/usr/share/man/man8 ${DESTDIR}/etc
+- install -m 755 -t ${DESTDIR}/usr/sbin makedumpfile $(VPATH)makedumpfile-R.pl
+- install -m 644 -t ${DESTDIR}/usr/share/man/man8 makedumpfile.8.gz
+- install -m 644 -t ${DESTDIR}/usr/share/man/man5 makedumpfile.conf.5.gz
++ install -m 755 -d ${DESTDIR}/usr/bin ${DESTDIR}/usr/share/man/man5 ${DESTDIR}/usr/share/man/man8 ${DESTDIR}/etc
++ install -m 755 -t ${DESTDIR}/usr/bin makedumpfile makedumpfile-R.pl
++ install -m 644 -t ${DESTDIR}/usr/share/man/man8 makedumpfile.8
++ install -m 644 -t ${DESTDIR}/usr/share/man/man5 makedumpfile.conf.5
+ install -m 644 -D $(VPATH)makedumpfile.conf ${DESTDIR}/etc/makedumpfile.conf.sample
+ mkdir -p ${DESTDIR}/usr/share/makedumpfile-${VERSION}/eppic_scripts
+ install -m 644 -t ${DESTDIR}/usr/share/makedumpfile-${VERSION}/eppic_scripts/ $(VPATH)eppic_scripts/*
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..515848e
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+0002-adapt-makefile-to-debian.patch