summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThadeu Lima de Souza Cascardo <cascardo@debian.org>2019-07-12 16:35:49 -0300
committerThadeu Lima de Souza Cascardo <cascardo@debian.org>2019-07-12 16:35:49 -0300
commite9e5c53a176ce6d07e0fee53982702735a5b78e1 (patch)
tree231273b0f1d5bfb21147fa2f1981b0eec9e831fe
parent8f363ddeac865662221136f9101561008c4e9fb1 (diff)
Commit patch queue (exported by git-debrebase)
[git-debrebase make-patches: export and commit patches]
-rw-r--r--debian/patches/0001-Remove-libebl-linkage.patch22
-rw-r--r--debian/patches/0002-adapt-makefile-to-debian.patch45
-rw-r--r--debian/patches/series2
3 files changed, 69 insertions, 0 deletions
diff --git a/debian/patches/0001-Remove-libebl-linkage.patch b/debian/patches/0001-Remove-libebl-linkage.patch
new file mode 100644
index 0000000..7a4f7a1
--- /dev/null
+++ b/debian/patches/0001-Remove-libebl-linkage.patch
@@ -0,0 +1,22 @@
+From: Louis Bouchard <louis.bouchard@ubuntu.com>
+Date: Mon, 17 Dec 2018 15:21:09 -0200
+Subject: Remove libebl from link options
+
+Description: Remove libebl from link options
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 1fdb628..df21b93 100644
+--- a/Makefile
++++ b/Makefile
+@@ -50,7 +50,7 @@ OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART))
+ SRC_ARCH = arch/arm.c arch/arm64.c arch/x86.c arch/x86_64.c arch/ia64.c arch/ppc64.c arch/s390x.c arch/ppc.c arch/sparc64.c
+ OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
+
+-LIBS = -ldw -lbz2 -lebl -ldl -lelf -lz
++LIBS = -ldw -lbz2 -ldl -lelf -lz
+ ifneq ($(LINKTYPE), dynamic)
+ LIBS := -static $(LIBS)
+ endif
diff --git a/debian/patches/0002-adapt-makefile-to-debian.patch b/debian/patches/0002-adapt-makefile-to-debian.patch
new file mode 100644
index 0000000..2e55af5
--- /dev/null
+++ b/debian/patches/0002-adapt-makefile-to-debian.patch
@@ -0,0 +1,45 @@
+From: Louis Bouchard <louis.bouchard@ubuntu.com>
+Date: Mon, 17 Dec 2018 15:21:09 -0200
+Subject: adapt-makefile-to-debian
+
+===================================================================
+---
+ Makefile | 18 +++++-------------
+ 1 file changed, 5 insertions(+), 13 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index df21b93..ed4fd1a 100644
+--- a/Makefile
++++ b/Makefile
+@@ -90,26 +90,18 @@ $(OBJ_ARCH): $(SRC_ARCH)
+
+ makedumpfile: $(SRC_BASE) $(OBJ_PART) $(OBJ_ARCH)
+ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJ_PART) $(OBJ_ARCH) -rdynamic -o $@ $< $(LIBS)
+- echo .TH MAKEDUMPFILE 8 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.8
+- grep -v "^.TH MAKEDUMPFILE 8" $(VPATH)makedumpfile.8 >> temp.8
+- mv temp.8 makedumpfile.8
+- gzip -c ./makedumpfile.8 > ./makedumpfile.8.gz
+- echo .TH MAKEDUMPFILE.CONF 5 \"$(DATE)\" \"makedumpfile v$(VERSION)\" \"Linux System Administrator\'s Manual\" > temp.5
+- grep -v "^.TH MAKEDUMPFILE.CONF 5" $(VPATH)makedumpfile.conf.5 >> temp.5
+- mv temp.5 makedumpfile.conf.5
+- gzip -c ./makedumpfile.conf.5 > ./makedumpfile.conf.5.gz
+
+ eppic_makedumpfile.so: extension_eppic.c
+ $(CC) $(CFLAGS) $(LDFLAGS) -shared -rdynamic -o $@ extension_eppic.c -fPIC -leppic -ltinfo
+
+ clean:
+- rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz makedumpfile.conf.5.gz
++ rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile
+
+ install:
+- install -m 755 -d ${DESTDIR}/usr/sbin ${DESTDIR}/usr/share/man/man5 ${DESTDIR}/usr/share/man/man8 ${DESTDIR}/etc
+- install -m 755 -t ${DESTDIR}/usr/sbin makedumpfile $(VPATH)makedumpfile-R.pl
+- install -m 644 -t ${DESTDIR}/usr/share/man/man8 makedumpfile.8.gz
+- install -m 644 -t ${DESTDIR}/usr/share/man/man5 makedumpfile.conf.5.gz
++ install -m 755 -d ${DESTDIR}/usr/bin ${DESTDIR}/usr/share/man/man5 ${DESTDIR}/usr/share/man/man8 ${DESTDIR}/etc
++ install -m 755 -t ${DESTDIR}/usr/bin makedumpfile makedumpfile-R.pl
++ install -m 644 -t ${DESTDIR}/usr/share/man/man8 makedumpfile.8
++ install -m 644 -t ${DESTDIR}/usr/share/man/man5 makedumpfile.conf.5
+ install -m 644 -D $(VPATH)makedumpfile.conf ${DESTDIR}/etc/makedumpfile.conf.sample
+ mkdir -p ${DESTDIR}/usr/share/makedumpfile-${VERSION}/eppic_scripts
+ install -m 644 -t ${DESTDIR}/usr/share/makedumpfile-${VERSION}/eppic_scripts/ $(VPATH)eppic_scripts/*
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..8d0f986
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,2 @@
+0001-Remove-libebl-linkage.patch
+0002-adapt-makefile-to-debian.patch