summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorPetr Tesarik <ptesarik@suse.cz>2012-10-31 16:12:47 +0900
committerAtsushi Kumagai <kumagai-atsushi@mxc.nes.nec.co.jp>2013-02-06 13:40:56 +0900
commit0aff0e5174d0708bf1bfb039ab863e1fea8a1029 (patch)
tree1e71b111c5594b027f0aafbbdf7819ba45985db9 /Makefile
parent5d83960cad23b2e7b9012d85d2cbd183ef026837 (diff)
[PATCH] keep dumpfile pages in a cache.
Add a simple cache for pages read from the dumpfile. This is a big win if we read consecutive data from one page, e.g. page descriptors, or even page table entries. Note that makedumpfile now always reads a complete page. This was already the case with kdump-compressed and sadump formats, but makedumpfile was throwing most of the data away. For the kdump-compressed case, we may actually save a lot of decompression, too. I tried to keep the cache small to minimize memory footprint, but it should be big enough to hold all pages to do 4-level paging plus some data. This is needed e.g. for vmalloc areas or Xen page frame table data, which are not contiguous in physical memory. Signed-off-by: Petr Tesarik <ptesarik@suse.cz>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 5b8df31..b5bba6f 100644
--- a/Makefile
+++ b/Makefile
@@ -40,8 +40,8 @@ CFLAGS_ARCH += -m32
endif
SRC = makedumpfile.c makedumpfile.h diskdump_mod.h sadump_mod.h sadump_info.h
-SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c
-OBJ_PART = print_info.o dwarf_info.o elf_info.o erase_info.o sadump_info.o
+SRC_PART = print_info.c dwarf_info.c elf_info.c erase_info.c sadump_info.c cache.c
+OBJ_PART = print_info.o dwarf_info.o elf_info.o erase_info.o sadump_info.o cache.o
SRC_ARCH = arch/arm.c arch/x86.c arch/x86_64.c arch/ia64.c arch/ppc64.c arch/s390x.c arch/ppc.c
OBJ_ARCH = arch/arm.o arch/x86.o arch/x86_64.o arch/ia64.o arch/ppc64.o arch/s390x.o arch/ppc.o