summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSuzuki K. Poulose <suzuki@in.ibm.com>2012-02-13 09:19:18 +0900
committerAtsushi Kumagai <kumagai-atsushi@mxc.nes.nec.co.jp>2012-02-13 09:19:18 +0900
commit3d8b733bb0a5be14fab76dd07cd10f340ba8e2f5 (patch)
tree88746c01446bd402f3cfb4d6cbaae065f078e6d8 /Makefile
parent96f24dc77dc48e4c8f4c3527f4f5b4d27845393c (diff)
[PATCH v1 2/3][ppc64] Rename the __powerpc__ macro to __powerpc64__ for PPC64.
Makedumpfile uses __powerpc__ as the value of ARCH to control the PPC64 specfic definitions. Rename this to __powerpc64__ for a better readability of the code as the support for ppc32 will be introduced in the later series. We could use __powerpc32__ for PPC32. Signed-off-by: Suzuki Poulose <suzuki@in.ibm.com> Signed-off-by: Atsushi Kumagai <kumagai-atsushi@mxc.nes.nec.co.jp>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 159f69d..c69138e 100644
--- a/Makefile
+++ b/Makefile
@@ -24,11 +24,12 @@ endif
ARCH := $(shell echo ${TARGET} | sed -e s/i.86/x86/ -e s/sun4u/sparc64/ \
-e s/arm.*/arm/ -e s/sa110/arm/ \
-e s/s390x/s390/ -e s/parisc64/parisc/ \
- -e s/ppc64/powerpc/ )
+ -e s/ppc64/powerpc64/ )
+
CFLAGS += -D__$(ARCH)__
CFLAGS_ARCH += -D__$(ARCH)__
-ifeq ($(ARCH), powerpc)
+ifeq ($(ARCH), powerpc64)
CFLAGS += -m64
CFLAGS_ARCH += -m64
endif