summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorNick Bartos <nick@pistoncloud.com>2013-08-16 12:47:21 +0900
committerAtsushi Kumagai <kumagai-atsushi@mxc.nes.nec.co.jp>2013-08-16 12:47:21 +0900
commitb0e1f0e2952ffb6b9e387b15fb62f33366b6d9f8 (patch)
tree9905cd71cb0b22fbdbaf31581d9cdc9c54778e26 /Makefile
parent16ae98a60bfd2696ccc2d7849be9caec45cbe558 (diff)
[PATCH v2] "make install" assumes directories exist.
The make install of makedumpfile-1.5.4 uses cp instead of the usual "install" command, which has some side effects of not pre-creating directories. This results in installs to an alternate DESTDIR fail because the parent directories do not exist. I have attached a patch which modifies make install to use the install utility. Signed-off-by: Nick Bartos <nick@pistoncloud.com> Change installation directory to /usr/sbin. Signed-off-by: Atsushi Kumagai <kumagai-atsushi@mxc.nes.nec.co.jp>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/Makefile b/Makefile
index 10178ba..2acea40 100644
--- a/Makefile
+++ b/Makefile
@@ -86,8 +86,8 @@ clean:
rm -f $(OBJ) $(OBJ_PART) $(OBJ_ARCH) makedumpfile makedumpfile.8.gz makedumpfile.conf.5.gz
install:
- cp makedumpfile ${DESTDIR}/bin
- cp makedumpfile-R.pl ${DESTDIR}/bin
- cp makedumpfile.8.gz ${DESTDIR}/usr/share/man/man8
- cp makedumpfile.conf.5.gz ${DESTDIR}/usr/share/man/man5
- cp makedumpfile.conf ${DESTDIR}/etc/makedumpfile.conf.sample
+ install -m 755 -d ${DESTDIR}/usr/sbin ${DESTDIR}/usr/share/man/man5 ${DESTDIR}/usr/share/man/man8 ${DESTDIR}/etc
+ install -m 755 -t ${DESTDIR}/usr/sbin makedumpfile makedumpfile-R.pl
+ install -m 644 -t ${DESTDIR}/usr/share/man/man8 makedumpfile.8.gz
+ install -m 644 -t ${DESTDIR}/usr/share/man/man5 makedumpfile.conf.5.gz
+ install -m 644 -D makedumpfile.conf ${DESTDIR}/etc/makedumpfile.conf.sample