summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules13
2 files changed, 14 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index ca8f5cf..14a75cb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
makedumpfile (1.3.5-1) UNRELEASED; urgency=low
* New upstream version
+ * Preserve upstream's original makedumpfile.8 in clean target
-- John Wright <jsw@debian.org> Thu, 17 Dec 2009 15:27:30 -0700
diff --git a/debian/rules b/debian/rules
index e039753..887f5c5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,6 +17,19 @@ override_dh_installinit:
# all the way until actual shutdown.
dh_installinit -pkdump-tools -- start 11 2 3 4 5 .
+# The upstream Makefile modifies makedumpfile.8 in place, so without this hack
+# (or a patch to the Makefile, which would be harder to maintain), our clean
+# target won't get us back to the original source.
+override_dh_auto_build:
+ cp makedumpfile.8 makedumpfile.8.orig
+ dh_auto_build
+
+override_dh_auto_clean:
+ if [ -f makedumpfile.8.orig ]; then \
+ mv makedumpfile.8.orig makedumpfile.8; \
+ fi
+ dh_auto_clean
+
guilt-patches:
dh_testdir
dh_quilt_unpatch