summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2002-09-15 22:54:38 +0000
committerColin Watson <cjwatson@debian.org>2002-09-15 22:54:38 +0000
commit9bba0df0f95753df47db312838773ef5380b0541 (patch)
tree757c35a37333317e9d06332f549f20781b578843
parentd283ca6c93f82e461c77fc043e7096e45a337612 (diff)
Upgrade to gettext 0.11.5.
-rw-r--r--configure.in2
-rw-r--r--docs/ChangeLog11
-rw-r--r--po/LINGUAS1
-rw-r--r--po/Makevars25
-rw-r--r--po/POTFILES.in3
-rwxr-xr-xtools/mkinstalldirs18
6 files changed, 53 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index 3dac9d1a..915d781c 100644
--- a/configure.in
+++ b/configure.in
@@ -287,8 +287,8 @@ AC_CHECK_HEADERS(string.h strings.h, break)
dnl
dnl Internationalization support.
dnl
-ALL_LINGUAS="ca cs da de es fr it ja"
AM_GNU_GETTEXT
+AM_GNU_GETTEXT_VERSION(0.11.5)
AC_SUBST(LINGUAS)dnl
dnl
dnl Checks for structures and compiler characteristics.
diff --git a/docs/ChangeLog b/docs/ChangeLog
index 6c700f0f..de7c491e 100644
--- a/docs/ChangeLog
+++ b/docs/ChangeLog
@@ -1,3 +1,14 @@
+Sun Sep 15 23:53:28 BST 2002 Colin Watson <cjwatson@debian.org>
+
+ Upgrade to gettext 0.11.5.
+
+ * configure.in: Remove ALL_LINGUAS. Add AM_GNU_GETTEXT_VERSION.
+ * po/LINGUAS: New file. Adds sv to the value of the old ALL_LINGUAS.
+ * po/Makevars: New file.
+ * po/POTFILES.in: Add src/fakesecurity.c. Change src/lexgrog.c to
+ src/lexgrog.l.
+ * tools/mkinstalldirs: Upgrade to current version.
+
Fri Sep 6 23:58:10 BST 2002 Colin Watson <cjwatson@debian.org>
* src/mandb.c (xcopy): Don't print the error from fopen() if it's
diff --git a/po/LINGUAS b/po/LINGUAS
new file mode 100644
index 00000000..d5fc6b8f
--- /dev/null
+++ b/po/LINGUAS
@@ -0,0 +1 @@
+ca cs da de es fr it ja sv
diff --git a/po/Makevars b/po/Makevars
new file mode 100644
index 00000000..1dc7d544
--- /dev/null
+++ b/po/Makevars
@@ -0,0 +1,25 @@
+# Makefile variables for PO directory in any package using GNU gettext.
+
+# Usually the message domain is the same as the package name.
+DOMAIN = $(PACKAGE)
+
+# These two variables depend on the location of this directory.
+subdir = po
+top_builddir = ..
+
+# These options get passed to xgettext.
+XGETTEXT_OPTIONS = --keyword=_ --keyword=N_
+
+# This is the copyright holder that gets inserted into the header of the
+# $(DOMAIN).pot file. Set this to the copyright holder of the surrounding
+# package. (Note that the msgstr strings, extracted from the package's
+# sources, belong to the copyright holder of the package.) Translators are
+# expected to transfer the copyright for their translations to this person
+# or entity, or to disclaim their copyright. The empty string stands for
+# the public domain; in this case the translators are expected to disclaim
+# their copyright.
+COPYRIGHT_HOLDER = Colin Watson <cjwatson@debian.org>
+
+# This is the list of locale categories, beyond LC_MESSAGES, for which the
+# message catalogs shall be used. It is usually empty.
+EXTRA_LOCALE_CATEGORIES =
diff --git a/po/POTFILES.in b/po/POTFILES.in
index a3ab1c76..65623786 100644
--- a/po/POTFILES.in
+++ b/po/POTFILES.in
@@ -7,7 +7,8 @@ src/catman.c
src/check_mandirs.c
src/compression.c
src/convert_name.c
-src/lexgrog.c
+src/fake_security.c
+src/lexgrog.l
src/man.c
src/mandb.c
src/manp.c
diff --git a/tools/mkinstalldirs b/tools/mkinstalldirs
index 0801ec2c..f8574a01 100755
--- a/tools/mkinstalldirs
+++ b/tools/mkinstalldirs
@@ -2,25 +2,33 @@
# mkinstalldirs --- make directory hierarchy
# Author: Noah Friedman <friedman@prep.ai.mit.edu>
# Created: 1993-05-16
-# Last modified: 1994-03-25
# Public domain
+# $Id: mkinstalldirs,v 1.1.1.1 2002/07/16 23:37:48 bruno Exp $
+
errstatus=0
-for file in ${1+"$@"} ; do
+for file
+do
set fnord `echo ":$file" | sed -ne 's/^:\//#/;s/^://;s/\// /g;s/^#/\//;p'`
shift
pathcomp=
- for d in ${1+"$@"} ; do
+ for d
+ do
pathcomp="$pathcomp$d"
case "$pathcomp" in
-* ) pathcomp=./$pathcomp ;;
esac
if test ! -d "$pathcomp"; then
- echo "mkdir $pathcomp" 1>&2
- mkdir "$pathcomp" || errstatus=$?
+ echo "mkdir $pathcomp"
+
+ mkdir "$pathcomp" || lasterr=$?
+
+ if test ! -d "$pathcomp"; then
+ errstatus=$lasterr
+ fi
fi
pathcomp="$pathcomp/"