summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2016-12-11 01:57:01 +0000
committerColin Watson <cjwatson@debian.org>2016-12-11 01:57:01 +0000
commit755a9551c45da82f99d0ad8e46ef756afbeafb3f (patch)
treec7dd282e7745108b2c22c5a4437d52fd52a3bbab /Makefile.am
parent0f06588d882febffdb890de8f902ac03e64e8eed (diff)
Fix distcheck following cache-owner/setuid changes
We previously ignored chown failures on "make install", but that's not really correct. Instead, configure with --disable-setuid during distcheck. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Add --disable-setuid.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 61a64d12..ba87b7b6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,9 +53,12 @@ EXTRA_DIST += \
gnulib/m4/uintmax_t.m4 \
gnulib/m4/visibility.m4
+# Installing in --enable-setuid mode (the default) requires root; disable
+# this so that distcheck can be run as non-root.
# The default for systemdtmpfilesdir is intentionally not prefix-sensitive,
# but we need to adjust it in order for distcheck to pass.
AM_DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-setuid \
--with-systemdtmpfilesdir=\$${prefix}/lib/tmpfiles.d
# We deliberately leave the configuration file in place on uninstall, since