summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2013-12-09 00:57:25 +0000
committerColin Watson <cjwatson@debian.org>2013-12-09 00:57:25 +0000
commit9201c0df303264717f2bd5342ac01bf7767f2cc4 (patch)
treecdbc8691d17ee06e8c67848edfce5205157a1e2e /Makefile.am
parent9f1a28cde987f0fbf9308fe62592f154de2345a0 (diff)
Automatically generate ChangeLog from git
* ChangeLog: Move to ... * ChangeLog-2013: ... here. * Makefile.am (EXTRA_DIST): Add ChangeLog-2013. (dist-hook): Add gen-ChangeLog. (gen-ChangeLog): New rule, based on that in coreutils. * gnulib: Import gitlog-to-changelog module.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 07d8fb78..a238966a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,6 +26,7 @@ dist_noinst_DATA = FAQ NEWS README include/README
EXTRA_DIST = \
.gitignore \
+ ChangeLog-2013 \
autogen.sh \
gnulib/m4/gnulib-cache.m4 \
gnulib/m4/gnulib-tool.m4 \
@@ -57,3 +58,16 @@ distuninstallcheck_listfiles = \
# http://lists.gnu.org/archive/html/bug-gnulib/2009-03/msg00154.html and
# thread.
ACLOCAL_AMFLAGS = -I gnulib/m4 -I m4
+
+dist-hook: gen-ChangeLog
+
+gen_start_date = '2013-12-09 00:52'
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/tools/gitlog-to-changelog \
+ --format='%s%n%n%b%n' \
+ --since="$(gen_start_date)" > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi