summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2014-11-16 22:28:07 +0000
committerColin Watson <cjwatson@debian.org>2014-11-16 22:28:07 +0000
commite5832504ac63bf1f5eba702ad41391acedc65ab2 (patch)
tree32ac571a8df3fca9d371b49c52cbe73ea298f687 /Makefile.in
parent879043ba1ea489baebd22674e3adf7652ec78d6b (diff)
Allow building from git without gnulib-tool
Since we don't want to keep Gnulib translations in revision control, we need gnulib-tool on $PATH when generating the build system in order to fetch them, but it's unnecessarily awkward to require everyone to have this just in order to build man-db from git. Allow building without this, although it is still required for "make dist". * configure.ac: No longer issue an error if gnulib/po/Makefile.in.in is missing. Instead, set the Automake conditional HAVE_GNULIB_PO to true if and only if gnulib/po/POTFILES.in exists, and only create gnulib/po/Makefile.in if gnulib/po/Makefile.in.in exists. * Makefile.am (SUBDIRS): Only include gnulib/po if HAVE_GNULIB_PO is true.
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index bdbff250..2cca839b 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -367,7 +367,8 @@ am__define_uniq_tagged_files = \
ETAGS = etags
CTAGS = ctags
CSCOPE = cscope
-DIST_SUBDIRS = $(SUBDIRS)
+DIST_SUBDIRS = docs gnulib/lib gnulib/po init lib libdb src man manual \
+ po tools
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
@@ -1399,7 +1400,8 @@ unlzma = @unlzma@
unxz = @unxz@
vgrind = @vgrind@
xz = @xz@
-SUBDIRS = docs gnulib/lib gnulib/po init lib libdb src man manual po tools
+@HAVE_GNULIB_PO_TRUE@GNULIB_PO = gnulib/po
+SUBDIRS = docs gnulib/lib $(GNULIB_PO) init lib libdb src man manual po tools
dist_noinst_DATA = FAQ NEWS README include/README
# These macro files are imported by gnulib-tool, but at present not used. We