summaryrefslogtreecommitdiff
path: root/bootstrap.conf
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2023-09-23 22:17:23 +0100
committerColin Watson <cjwatson@debian.org>2023-09-23 22:17:23 +0100
commitc0cbb6e4f5cb2a778be6aa75daabbe8cf41686a8 (patch)
treecf06f6e7ea318fd4c5c4904bd1eb8f86cebcb747 /bootstrap.conf
parent0b7139d556a20a51aab0e70ae508eab3f3532473 (diff)
parent10ffa2be71a9ba46c4328b3792a2001f4092625d (diff)
New upstream release (2.12.0)
Diffstat (limited to 'bootstrap.conf')
-rw-r--r--bootstrap.conf54
1 files changed, 40 insertions, 14 deletions
diff --git a/bootstrap.conf b/bootstrap.conf
index 63883feb..caee513b 100644
--- a/bootstrap.conf
+++ b/bootstrap.conf
@@ -16,7 +16,7 @@
# along with this program. If not, see <https://www.gnu.org/licenses/>.
-GNULIB_REVISION=df336dc1ae60d8ad9f452f2234951133fe617bb0
+GNULIB_REVISION=d1b40e09c9c04d5c1ff120373397c6180bc16beb
# gnulib modules used by this package.
gnulib_modules="
@@ -90,17 +90,35 @@ gnulib_modules="
xstdopen
xstrndup
xvasprintf
+ year2038-recommended
"
gnulib_tool_option_extras="\
- --po-base=gl/ref-po \
--no-conditional-dependencies \
--libtool \
--macro-prefix=gl \
- --po-domain=man-db \
--no-vc-files \
"
+# bootstrap's --skip-po option really just controls its own downloads, but
+# it's somewhat useful to provide a way to skip the downloads performed by
+# gnulib-tool as well. Since we always suppress bootstrap's downloads due
+# to maintaining man-db's own translations manually, we need to parse the
+# command line ourselves to find out whether --skip-po was explicitly
+# passed.
+explicit_skip_po=
+for option; do
+ case $option in
+ --skip-po)
+ explicit_skip_po=t
+ ;;
+ esac
+done
+
+if [ -z "$explicit_skip_po" ]; then
+ gnulib_tool_option_extras="$gnulib_tool_option_extras --po-base=gl/ref-po --po-domain=man-db"
+fi
+
# This doesn't currently exist, but we set it to avoid confusion with 'gl'
# as the local output directory.
local_gl_dir=gnulib-local
@@ -139,19 +157,27 @@ tar -
bootstrap_post_import_hook () {
patch -s -p1 <patches/argp-domain.patch
- # gnulib-tool installs its own versions of gettext infrastructure files
- # such as po/Makefile.in.in, which don't necessarily match our configured
- # AM_GNU_GETTEXT_VERSION. To cope with this, we tell gnulib-tool to
- # install into a temporary directory (using --po-base above) and fix
- # things up here.
- cp -a gl/ref-po/LINGUAS gl/ref-po/POTFILES.in gl/po/
- sed 's,^subdir *=.*,subdir = gl/po,' gl/ref-po/Makevars >gl/po/Makevars
- if ls gl/ref-po/*.po >/dev/null 2>&1; then
- cp -a gl/ref-po/*.po gl/po/
+ if [ -z "$explicit_skip_po" ]; then
+ # gnulib-tool installs its own versions of gettext infrastructure files
+ # such as po/Makefile.in.in, which don't necessarily match our
+ # configured AM_GNU_GETTEXT_VERSION. To cope with this, we tell
+ # gnulib-tool to install into a temporary directory (using --po-base
+ # above) and fix things up here.
+ cp -a gl/ref-po/LINGUAS gl/ref-po/POTFILES.in gl/po/
+ sed 's,^subdir *=.*,subdir = gl/po,' gl/ref-po/Makevars >gl/po/Makevars
+ if ls gl/ref-po/*.po >/dev/null 2>&1; then
+ cp -a gl/ref-po/*.po gl/po/
+ fi
+ rm -rf gl/ref-po
fi
- rm -rf gl/ref-po
}
bootstrap_epilogue () {
- mv INSTALL docs/INSTALL.autoconf
+ # If --copy is not used, then INSTALL may be a symbolic link, in which
+ # case a simple "mv" could leave it pointing to the wrong target. Arrange
+ # (reasonably portably) for the target to end up as a regular file no
+ # matter what.
+ rm -f docs/INSTALL.autoconf
+ cp -Lp INSTALL docs/INSTALL.autoconf
+ rm -f INSTALL
}