summaryrefslogtreecommitdiff
path: root/config.h.in
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-11-28 15:01:37 +0000
committerColin Watson <cjwatson@debian.org>2010-11-28 15:01:37 +0000
commit6e52ef210a440618ecc65180a57fcd6a1fe7758b (patch)
tree501249fa45daef947960ff7fe136c41f1b225b89 /config.h.in
parenta7aab9879f7abf31ee4cf849da79dd98b5ddf3a2 (diff)
Remove internal copy of libpipeline.
* configure.ac: Remove --enable-socketpair-pipe and --with-external-pipeline options. Remove INTERNAL_PIPELINE Automake conditional. Check for libpipeline unconditionally. * docs/INSTALL.quick: Mention the need to install libpipeline. * gnulib: Remove strsignal and sys_select modules. * lib/Makefile.am (libman_la_SOURCES): Never add pipeline.c or pipeline.h. * lib/pipeline.c, lib/pipeline.h: Remove. * m4/man-socketpair.m4: Remove. * NEWS: Document this. Bump to 2.6.0.
Diffstat (limited to 'config.h.in')
-rw-r--r--config.h.in94
1 files changed, 0 insertions, 94 deletions
diff --git a/config.h.in b/config.h.in
index cb776301..92453a4d 100644
--- a/config.h.in
+++ b/config.h.in
@@ -45,9 +45,6 @@
source. */
#undef COMP_SRC
-/* Define if shutdown(2) does not set modes for socket descriptor. */
-#undef CORRECT_SOCKETPAIR_MODE
-
/* Define to one of `_getb67', `GETB67', `getb67' for Cray-2 and Cray-YMP
systems. This function is required for `alloca.c' support on those systems.
*/
@@ -265,9 +262,6 @@
/* Define to 1 when the gnulib module sleep should be tested. */
#undef GNULIB_TEST_SLEEP
-/* Define to 1 when the gnulib module snprintf should be tested. */
-#undef GNULIB_TEST_SNPRINTF
-
/* Define to 1 when the gnulib module stat should be tested. */
#undef GNULIB_TEST_STAT
@@ -289,9 +283,6 @@
/* Define to 1 when the gnulib module strsep should be tested. */
#undef GNULIB_TEST_STRSEP
-/* Define to 1 when the gnulib module strsignal should be tested. */
-#undef GNULIB_TEST_STRSIGNAL
-
/* Define to 1 when the gnulib module unlink should be tested. */
#undef GNULIB_TEST_UNLINK
@@ -459,10 +450,6 @@
*/
#undef HAVE_DECL_SLEEP
-/* Define to 1 if you have the declaration of `snprintf', and to 0 if you
- don't. */
-#undef HAVE_DECL_SNPRINTF
-
/* Define to 1 if you have the declaration of `strdup', and to 0 if you don't.
*/
#undef HAVE_DECL_STRDUP
@@ -487,14 +474,6 @@
don't. */
#undef HAVE_DECL_STRNLEN
-/* Define to 1 if you have the declaration of `strsignal', and to 0 if you
- don't. */
-#undef HAVE_DECL_STRSIGNAL
-
-/* Define to 1 if you have the declaration of `sys_siglist', and to 0 if you
- don't. */
-#undef HAVE_DECL_SYS_SIGLIST
-
/* Define to 1 if you have the declaration of `vsnprintf', and to 0 if you
don't. */
#undef HAVE_DECL_VSNPRINTF
@@ -503,10 +482,6 @@
don't. */
#undef HAVE_DECL__SNPRINTF
-/* Define to 1 if you have the declaration of `_sys_siglist', and to 0 if you
- don't. */
-#undef HAVE_DECL__SYS_SIGLIST
-
/* Define to 1 if you have the <dirent.h> header file, and it defines `DIR'.
*/
#undef HAVE_DIRENT_H
@@ -777,21 +752,12 @@
/* Define to 1 if you have the `rawmemchr' function. */
#undef HAVE_RAWMEMCHR
-/* Define to 1 if accept is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_ACCEPT
-
-/* Define to 1 if accept4 is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_ACCEPT4
-
/* Define to 1 if alphasort is declared even after undefining macros. */
#undef HAVE_RAW_DECL_ALPHASORT
/* Define to 1 if atoll is declared even after undefining macros. */
#undef HAVE_RAW_DECL_ATOLL
-/* Define to 1 if bind is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_BIND
-
/* Define to 1 if btowc is declared even after undefining macros. */
#undef HAVE_RAW_DECL_BTOWC
@@ -802,9 +768,6 @@
/* Define to 1 if chown is declared even after undefining macros. */
#undef HAVE_RAW_DECL_CHOWN
-/* Define to 1 if connect is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_CONNECT
-
/* Define to 1 if dirfd is declared even after undefining macros. */
#undef HAVE_RAW_DECL_DIRFD
@@ -898,15 +861,6 @@
/* Define to 1 if getpagesize is declared even after undefining macros. */
#undef HAVE_RAW_DECL_GETPAGESIZE
-/* Define to 1 if getpeername is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_GETPEERNAME
-
-/* Define to 1 if getsockname is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_GETSOCKNAME
-
-/* Define to 1 if getsockopt is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_GETSOCKOPT
-
/* Define to 1 if getsubopt is declared even after undefining macros. */
#undef HAVE_RAW_DECL_GETSUBOPT
@@ -934,9 +888,6 @@
/* Define to 1 if linkat is declared even after undefining macros. */
#undef HAVE_RAW_DECL_LINKAT
-/* Define to 1 if listen is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_LISTEN
-
/* Define to 1 if lseek is declared even after undefining macros. */
#undef HAVE_RAW_DECL_LSEEK
@@ -1033,12 +984,6 @@
/* Define to 1 if realpath is declared even after undefining macros. */
#undef HAVE_RAW_DECL_REALPATH
-/* Define to 1 if recv is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_RECV
-
-/* Define to 1 if recvfrom is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_RECVFROM
-
/* Define to 1 if renameat is declared even after undefining macros. */
#undef HAVE_RAW_DECL_RENAMEAT
@@ -1051,30 +996,15 @@
/* Define to 1 if scandir is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SCANDIR
-/* Define to 1 if select is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_SELECT
-
-/* Define to 1 if send is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_SEND
-
-/* Define to 1 if sendto is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_SENDTO
-
/* Define to 1 if setenv is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SETENV
-/* Define to 1 if setsockopt is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_SETSOCKOPT
-
/* Define to 1 if setstate_r is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SETSTATE_R
/* Define to 1 if setusershell is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SETUSERSHELL
-/* Define to 1 if shutdown is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_SHUTDOWN
-
/* Define to 1 if sigaction is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SIGACTION
@@ -1105,9 +1035,6 @@
/* Define to 1 if snprintf is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SNPRINTF
-/* Define to 1 if socket is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_SOCKET
-
/* Define to 1 if srandom_r is declared even after undefining macros. */
#undef HAVE_RAW_DECL_SRANDOM_R
@@ -1231,9 +1158,6 @@
/* Define if you have refer. */
#undef HAVE_REFER
-/* Define to 1 if the system has the type `sa_family_t'. */
-#undef HAVE_SA_FAMILY_T
-
/* Define to 1 if you have the <search.h> header file. */
#undef HAVE_SEARCH_H
@@ -1249,9 +1173,6 @@
/* Define to 1 if you have the `setreuid' function. */
#undef HAVE_SETREUID
-/* Define to 1 if you have the `shutdown' function. */
-#undef HAVE_SHUTDOWN
-
/* Define to 1 if you have the `sigaction' function. */
#undef HAVE_SIGACTION
@@ -1342,9 +1263,6 @@
/* Define to 1 if you have the `strsep' function. */
#undef HAVE_STRSEP
-/* Define to 1 if you have the `strsignal' function. */
-#undef HAVE_STRSIGNAL
-
/* Define if there is a member named d_type in the struct describing directory
headers. */
#undef HAVE_STRUCT_DIRENT_D_TYPE
@@ -1355,9 +1273,6 @@
/* Define to 1 if `sa_sigaction' is a member of `struct sigaction'. */
#undef HAVE_STRUCT_SIGACTION_SA_SIGACTION
-/* Define to 1 if the system has the type `struct sockaddr_storage'. */
-#undef HAVE_STRUCT_SOCKADDR_STORAGE
-
/* Define to 1 if you have the <sysexits.h> header file. */
#undef HAVE_SYSEXITS_H
@@ -1387,9 +1302,6 @@
/* Define to 1 if you have the <sys/param.h> header file. */
#undef HAVE_SYS_PARAM_H
-/* Define to 1 if you have the <sys/select.h> header file. */
-#undef HAVE_SYS_SELECT_H
-
/* Define to 1 if you have the <sys/socket.h> header file. */
#undef HAVE_SYS_SOCKET_H
@@ -1498,9 +1410,6 @@
/* Define to 1 if `vfork' works. */
#undef HAVE_WORKING_VFORK
-/* Define to 1 if you have the <ws2tcpip.h> header file. */
-#undef HAVE_WS2TCPIP_H
-
/* Define if you have xz. */
#undef HAVE_XZ
@@ -1706,9 +1615,6 @@
weak. */
#undef USE_PTH_THREADS_WEAK
-/* Define if socketpair(2) can be used as a fast replacement for pipe(2). */
-#undef USE_SOCKETPAIR_PIPE
-
/* Define if the old Solaris multithreading library can be used. */
#undef USE_SOLARIS_THREADS