summaryrefslogtreecommitdiff
path: root/config.h.in
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2011-03-24 01:04:14 +0000
committerColin Watson <cjwatson@debian.org>2011-03-24 01:04:14 +0000
commit8d3522e1e4be59e44ab07bbedc77be903d17eb56 (patch)
treef660da74f18b72848fb79672cf625ce630a14ef7 /config.h.in
parent34b38e61fd4f1ed342c47390646606839282724a (diff)
Rewrite all remaining subprocess handling in terms of libpipeline.
* lib/security.c (do_system_drop_privs_child): New function. (do_system_drop_privs): Rewrite using libpipeline. * src/catman.c (post_fork): New function. (catman): Rewrite using libpipeline. (add_arg): Rewrite as a wrapper around pipecmd_arg. (do_catman): Remove. (reset_cursor): Remove. (parse_for_sec): Use libpipeline for subprocess handling. (main): Install custom post-fork handler. * src/man.c (gripe_no_man) [_AIX || __sgi]: Rewrite vendor fallback using libpipeline. * src/Makefile.am (catman_LDADD): Add $(libpipeline_LIBS). * src/catman.c (main): Duplicate the output of setlocale if non-NULL. * configure.ac (AC_FUNC_VFORK): Remove. (AC_REPLACE_FUNCS): Remove waitpid. * gnulib: Remove waitpid module. * lib/README: Remove waitpid.c. * lib/waitpid.c: Remove.
Diffstat (limited to 'config.h.in')
-rw-r--r--config.h.in9
1 files changed, 0 insertions, 9 deletions
diff --git a/config.h.in b/config.h.in
index f0cc899e..83d2b2bc 100644
--- a/config.h.in
+++ b/config.h.in
@@ -299,9 +299,6 @@
/* Define to 1 when the gnulib module vsnprintf should be tested. */
#undef GNULIB_TEST_VSNPRINTF
-/* Define to 1 when the gnulib module waitpid should be tested. */
-#undef GNULIB_TEST_WAITPID
-
/* Define to 1 when the gnulib module wcrtomb should be tested. */
#undef GNULIB_TEST_WCRTOMB
@@ -1155,9 +1152,6 @@
/* Define to 1 if vsnprintf is declared even after undefining macros. */
#undef HAVE_RAW_DECL_VSNPRINTF
-/* Define to 1 if waitpid is declared even after undefining macros. */
-#undef HAVE_RAW_DECL_WAITPID
-
/* Define to 1 if wcpcpy is declared even after undefining macros. */
#undef HAVE_RAW_DECL_WCPCPY
@@ -1467,9 +1461,6 @@
/* Define to 1 if you have the `vsnprintf' function. */
#undef HAVE_VSNPRINTF
-/* Define to 1 if you have the `waitpid' function. */
-#undef HAVE_WAITPID
-
/* Define to 1 if you have the <wchar.h> header file. */
#undef HAVE_WCHAR_H