summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-12-31 22:38:15 +0000
committerColin Watson <cjwatson@debian.org>2022-12-31 22:38:15 +0000
commit206b2ff154d0793b344abb09d5b4459e331554aa (patch)
tree77df8d97e1ee6e79045812923e2ba5afc87f2e4d /configure.ac
parentf7c775bd3bcd408eea178371e932b5496a8a2602 (diff)
Fix compile and test failures when troff is not groff
Fixes https://gitlab.com/man-db/man-db/-/issues/12. * src/man.c (ONLY_TROFF_IS_GROFF): Only define if `HAS_TROFF` is defined. (init_html_pager): Only define if `TROFF_IS_GROFF` is defined. (format_display): Mark `man_file` as unused if `TROFF_IS_GROFF` is not defined. * configure.ac: Substitute `troff_is_groff`. * src/tests/Makefile.am (TESTS_ENVIRONMENT): Export `troff_is_groff`. * src/tests/man-language-specific-requests: Adjust expected language-specific requests if `troff_is_groff` is not `yes`. * NEWS.md: Document this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cacf2391..fa1757c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -196,6 +196,7 @@ else
AC_CHECK_PROGS([troff], [troff gtroff])
TROFF=troff
fi
+AC_SUBST([troff_is_groff])
AC_SUBST([TROFF])
if test -n "$troff"
then