summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-08-22 23:41:41 +0100
committerColin Watson <cjwatson@debian.org>2019-08-22 23:41:41 +0100
commit2519d2ffe769a4059bfe475a092afa40722eb38d (patch)
tree95ae2180c56b1d64021ef0f2c3c236dd9c171073 /configure.ac
parent329359c2bcc4023a8f4f72ff50f8c72208e0b46d (diff)
Move decompression code out of libman
Fixes Savannah bug #56734. * configure.ac: Remove incorrect Darwin workaround. * lib/decompress.c: Move to ... * src/decompress.c: ... here. * lib/decompress.h: Move to ... * src/decompress.h: ... here. * lib/Makefile.am (libman_la_SOURCES): Remove decompress.c and decompress.h. (libman_la_LIBADD): Remove $(LIBCOMPRESS). * lib/README: Remove decompress.*. * lib/encodings.c: Remove unused #include "decompress.h". * src/Makefile.am (lexgrog_LDADD, man_LDADD, manconv_LDADD, mandb_LDADD, zsoelim_LDADD): Add $(LIBCOMPRESS). (lexgrog_SOURCES, man_SOURCES, manconv_SOURCES, mandb_SOURCES, zsoelim_SOURCES): Add decompress.c and decompress.h. * NEWS: Document this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 0 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index ca12c0a5..eaba176e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,13 +60,6 @@ case $host_os in
dnl environment:
CFLAGS="$CFLAGS -YPOSIX"
;;
- *darwin*)
- dnl libman intentionally has an undefined "sandbox" symbol
- dnl which is supplied by each application. The Darwin
- dnl linker refuses to do this by default, and needs some
- dnl help.
- CFLAGS="$CFLAGS -Wl,-flat_namespace,-undefined,suppress"
- ;;
esac
if test "$GCC" = yes
then