summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBernhard Rosenkränzer <bero@lindev.ch>2020-06-01 01:07:13 +0100
committerColin Watson <cjwatson@debian.org>2020-06-01 01:07:13 +0100
commit9966be79c3f24876d5f628730fc0e0e2330eb2bf (patch)
treea6a6f6aef6676581b8a4214efd3f274030f25264 /configure.ac
parentaba742e89660a83adec28ec2353fab2b95de8773 (diff)
Add support for zstd-compressed manual pages
* configure.ac: Check for zstd. * include/comp_src.h.in (comp_list): Add zstd. * include/manconfig.h.in: Define UNZSTD. * NEWS: Document this.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3406c5e6..5aefa5c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,6 +327,11 @@ if test -n "$lzip"
then
unlzip="$lzip -dc"
fi
+MAN_CHECK_PROGS([zstd], [ZSTD], [use ZSTD as zstd compression utility], [zstd])
+if test -n "$zstd"
+then
+ unzstd="$zstd -dc"
+fi
if test -n "$compressor"
then
AC_DEFINE([COMP_CAT], [1], [Define if you have compressors and want to support compressed cat files.])
@@ -339,6 +344,7 @@ AC_SUBST([bunzip2])
AC_SUBST([unlzma])
AC_SUBST([unxz])
AC_SUBST([unlzip])
+AC_SUBST([unzstd])
MAN_COMPRESS_LIB([z], [gzopen])
dnl To add more decompressors just follow the scheme above.