summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-01-16 15:34:51 +0000
committerColin Watson <cjwatson@debian.org>2022-01-16 15:34:52 +0000
commit000cda3ec5f121a5c279bd5a8074f027ba0efd1f (patch)
treeda454588a81593cc548f6baa5c823d2c47e21e7d /include
parente01d6a881db897a7002ee70f1f990728c73239ed (diff)
Stop generating include/*.h from configure
This was inconvenient when making changes to those central header files. All `configure`-generated preprocessor symbols are now in `config.h`. * configure.ac: Define various PROG_* symbols. Remove AC_SUBST calls for compressors and decompressors. (AC_CONFIG_FILES): Remove include/comp_src.h and include/manconfig.h. * m4/man-arg-override-dir.m4: Define OVERRIDE_DIR symbol. * include/manconfig.h.in: Rename to ... * include/manconfig.h: ... this. Remove PROG_*, OVERRIDE_DIR, and COMPRESS_EXT definitions. * include/comp_src.h.in: Rename to ... * include/comp_src.h: ... this. * README.md: Update references to include/manconfig.h. * .gitignore: Remove include/*.h.
Diffstat (limited to 'include')
-rw-r--r--include/comp_src.h (renamed from include/comp_src.h.in)4
-rw-r--r--include/manconfig.h (renamed from include/manconfig.h.in)100
2 files changed, 5 insertions, 99 deletions
diff --git a/include/comp_src.h.in b/include/comp_src.h
index 6827d550..2be2614b 100644
--- a/include/comp_src.h.in
+++ b/include/comp_src.h
@@ -1,8 +1,8 @@
-/* @configure_input@
- *
+/*
* comp_src.h: structure used by decompress.c
*
* Copyright (C) 1994 Graeme W. Wilford. (Wilf.)
+ * Copyright (C) 2003-2022 Colin Watson.
*
* This file is part of man-db.
*
diff --git a/include/manconfig.h.in b/include/manconfig.h
index 61a2194b..feebd208 100644
--- a/include/manconfig.h.in
+++ b/include/manconfig.h
@@ -1,9 +1,8 @@
-/* @configure_input@
- *
- * manconfig.h.in: definitions and declarations used throughout man-db
+/*
+ * manconfig.h: definitions and declarations used throughout man-db
*
* Copyright (C) 1994, 1995 Graeme W. Wilford. (Wilf.)
- * Copyright (C) 2001, 2002 Colin Watson.
+ * Copyright (C) 2001-2022 Colin Watson.
*
* This file is part of man-db.
*
@@ -97,77 +96,6 @@
#define MAN_DB "/index" DB_EXT
#define mkdbname(path) xasprintf ("%s%s", path, MAN_DB)
-/* The locations of the following files were determined by ../configure so
- some of them may be incorrect. Edit as necessary */
-
-#ifndef PROG_PAGER
-# define PROG_PAGER "@pager@"
-#endif
-
-#ifndef PROG_CAT
-# define PROG_CAT "@cat@"
-#endif
-
-#ifndef PROG_BROWSER
-# define PROG_BROWSER "@browser@"
-#endif
-
-#ifndef PROG_TR
-# define PROG_TR "@tr@"
-#endif
-
-#ifndef PROG_GREP
-# define PROG_GREP "@grep@"
-#endif
-
-#ifdef HAS_TROFF
-# ifndef PROG_TROFF
-# define PROG_TROFF "@troff@"
-# endif
-#endif
-
-#ifndef NROFF_MISSING
-# ifndef PROG_NROFF
-# define PROG_NROFF "@nroff@"
-# endif
-#endif
-
-#ifndef PROG_EQN
-# define PROG_EQN "@eqn@"
-#endif
-
-#ifndef PROG_NEQN
-# define PROG_NEQN "@neqn@"
-#endif
-
-#ifndef PROG_TBL
-# define PROG_TBL "@tbl@"
-#endif
-
-#ifndef PROG_COL
-# define PROG_COL "@col@"
-#endif
-
-#ifndef PROG_VGRIND
-# define PROG_VGRIND "@vgrind@"
-#endif
-
-#ifndef PROG_REFER
-# define PROG_REFER "@refer@"
-#endif
-
-#ifndef PROG_GRAP
-# define PROG_GRAP "@grap@"
-#endif
-
-#ifndef PROG_PIC
-# define PROG_PIC "@pic@"
-#endif
-
-#ifndef OVERRIDE_DIR
-# define OVERRIDE_DIR "@override_dir@"
-#endif
-
/*------------------------------------------------------------------*/
/* The following definitions are best left alone by the uninitiated */
/*------------------------------------------------------------------*/
@@ -205,28 +133,6 @@
# define TR_SET2 " \'\\055\\157\\047\\170\'"
#endif
-#ifdef COMP_CAT
-/* This is the default compressor and compressed extension.
- These are used for compressing cat pages. The compressor is likely to
- be gzip or compress and the extension: .gz or .Z . Please make sure that
- all of your cat pages have the same extension (whatever that may be) */
-
-# define PROG_COMPRESSOR "@compressor@"
-# define COMPRESS_EXT "@compress_ext@"
-#endif /* COMP_CAT */
-
-/* These are the currently supported decompressors. They are used for
- decompressing cat pages and source nroff. To add further decompressors,
- you will need to edit comp_src.h[.in] . Help is provided in the file */
-
-#define PROG_GUNZIP "@gunzip@"
-#define PROG_UNCOMPRESS "@uncompress@"
-#define PROG_BUNZIP2 "@bunzip2@"
-#define PROG_UNLZMA "@unlzma@"
-#define PROG_UNXZ "@unxz@"
-#define PROG_UNLZIP "@unlzip@"
-#define PROG_UNZSTD "@unzstd@"
-
/*-----------------------------------------------------------------------*/
/* The things below here shouldn't really be changed unless you really */
/* know what you are doing. */