summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-01-16 12:54:04 +0000
committerColin Watson <cjwatson@debian.org>2022-01-16 12:54:04 +0000
commit24b6317bfc3543b93c85130e06bbc4d066910609 (patch)
treec2161d2ac423f30ec12b6b8ca0660a787cb697f8 /include
parent59f1bd7e16798d8d99d4d68aa5d591c7380f7b2c (diff)
Move lexgrog-related bits out of manconfig.h
It's generally cleaner for things like this to be in a dedicated header file. * include/manconfig.h.in (struct lexgrog, find_name, find_name_decompressed): Move to ... * src/lexgrog.h: ... here (new file). Simplify declarations slightly. * include/manconfig.h.in (lexgrog filter enum): Move to ... * src/lexgrog.l: ... here. * src/Makefile.am (lexgrog_SOURCES, mandb_SOURCES): Add lexgrog.h. * src/check_mandirs.c, src/lexgrog.l, src/lexgrog_test.c, src/straycats.c: Include lexgrog.h.
Diffstat (limited to 'include')
-rw-r--r--include/manconfig.h.in23
1 files changed, 0 insertions, 23 deletions
diff --git a/include/manconfig.h.in b/include/manconfig.h.in
index 52431104..a2d02e6c 100644
--- a/include/manconfig.h.in
+++ b/include/manconfig.h.in
@@ -306,13 +306,6 @@ extern struct compression *comp_file (const char *filename);
/* straycats.c */
extern int straycats (const char *database, const char *manpath);
-/* lexgrog.l */
-struct lexgrog;
-extern int find_name (const char *file, const char *filename,
- struct lexgrog *p_lg, const char *encoding);
-extern int find_name_decompressed (struct pipeline *p, const char *filename,
- struct lexgrog *p_lg);
-
/* util.c */
extern int is_changed (const char *fa, const char *fb);
extern int is_directory (const char *path);
@@ -367,20 +360,4 @@ extern int quiet; /* be quiet(er) if 1 */
#define VER_KEY "$version$" /* version key */
#define VER_ID "2.5.0" /* version content */
-/* defines the ordered list of filters detected by lexgrog */
-enum { TBL_FILTER=0 /* tbl */
- , EQN_FILTER /* eqn */
- , PIC_FILTER /* pic */
- , GRAP_FILTER /* grap */
- , REF_FILTER /* refer */
- , VGRIND_FILTER /* vgrind */
- , MAX_FILTERS /* delimiter */
- };
-
-typedef struct lexgrog {
- int type;
- char *whatis;
- char *filters;
-} lexgrog;
-
#endif /* MANCONFIG_H */