summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-01-02 03:02:41 +0000
committerColin Watson <cjwatson@debian.org>2022-01-02 03:02:41 +0000
commit2b1e6c60072d2a933abffdad59b52202b286b24a (patch)
treea6773809980e6c797b7d29f043a71cbfafb8b5b9 /include
parent2ce26131ac9cb7444367c809f674624320e8e8e2 (diff)
Update to Gnulib 20211231
In line with Gnulib, we now require Autoconf 2.64. * bootstrap: Sync to Gnulib 14db2b71b5bd05b94ec6126617fd32cd5f1016cd. * bootstrap.conf (GNULIB_REVISION): Set to 14db2b71b5bd05b94ec6126617fd32cd5f1016cd. (buildreq): Bump required autoconf version to 2.64. * configure.ac (AC_PREREQ): Bump to 2.64. (--enable-gcc-warnings): New option, based on code in coreutils. Use this to enable -fanalyzer only if --enable-gcc-warnings=expensive is used; it's useful but slow. * include/manconfig.h.in (create_tempdir, appendstr): Move NODISCARD to the start of these function declarations, required by draft C2x. * patches/argp-domain.patch: Rebase. * NEWS: Document this.
Diffstat (limited to 'include')
-rw-r--r--include/manconfig.h.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/manconfig.h.in b/include/manconfig.h.in
index ffc719e3..52431104 100644
--- a/include/manconfig.h.in
+++ b/include/manconfig.h.in
@@ -288,7 +288,7 @@ extern struct compression comp_list[];
#include "attribute.h"
#include "xalloc.h"
#include "xstrndup.h"
-extern char *create_tempdir (const char *template) NODISCARD;
+NODISCARD extern char *create_tempdir (const char *template);
extern bool debug_level; /* shows whether -d issued */
extern void init_debug (void);
@@ -322,7 +322,7 @@ extern char *trim_spaces (const char *s);
extern char *lang_dir (const char *filename);
extern void init_locale (void);
-extern char *appendstr (char *, ...) ATTRIBUTE_SENTINEL () NODISCARD;
+NODISCARD extern char *appendstr (char *, ...) ATTRIBUTE_SENTINEL ();
extern int quiet; /* be quiet(er) if 1 */