summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2005-07-03 19:57:45 +0000
committerColin Watson <cjwatson@debian.org>2005-07-03 19:57:45 +0000
commit2e32faefb57d694f479c433160467b40335b2f0b (patch)
tree03d6fa4610a9a6d8ec675e677f330d3ef14e2b40 /include
parentcd38e0d1ddd3c8f09f469bb49f6185039e453155 (diff)
* configure.in: Define HAVE_GZIP, HAVE_COMPRESS, and HAVE_BZIP2 as
appropriate. * include/comp_src.h.in: Conditionalise compressor list on HAVE_GZIP, HAVE_COMPRESS, and HAVE_BZIP2 rather than on GUNZIP, UNCOMPRESS, and BUNZIP2; if a compressor isn't detected, the latter will end up as empty strings, not undefined. Thanks to Paul Slootman (Debian bug #196097). * docs/NEWS: Document this.
Diffstat (limited to 'include')
-rw-r--r--include/comp_src.h.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/include/comp_src.h.in b/include/comp_src.h.in
index 9709e062..f0ac0486 100644
--- a/include/comp_src.h.in
+++ b/include/comp_src.h.in
@@ -47,20 +47,20 @@
struct compression comp_list[] = {
/* If we have gzip, incorporate the following */
-#ifdef GUNZIP
+#ifdef HAVE_GZIP
{GUNZIP, "gz", NULL},
{GUNZIP, "z", NULL},
-#endif /* GUNZIP */
+#endif /* HAVE_GZIP */
/* If we have compress, incorporate the following */
-#ifdef UNCOMPRESS
+#ifdef HAVE_COMPRESS
{UNCOMPRESS, "Z", NULL},
-#endif /* UNCOMPRESS */
+#endif /* HAVE_COMPRESS */
/* If we have bzip2, incorporate the following */
-#ifdef BUNZIP2
+#ifdef HAVE_BZIP2
{BUNZIP2, "bz2", NULL},
-#endif /* BUNZIP2 */
+#endif /* HAVE_BZIP2 */
/*------------------------------------------------------*/
/* Add your decompressor(s) and extension(s) below here */