summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-01-16 16:45:46 +0000
committerColin Watson <cjwatson@debian.org>2022-01-16 16:45:46 +0000
commit4e3a383c3a7a47533b047c8fde509d990058bbdd (patch)
treec9d848c58e1f2660c89b2d1b09abed6a9ac5d7ca /include
parent1b32c829e19e4d47776274d9d8b5b59345cb7c56 (diff)
Move util.c-related declarations out of manconfig.h
* include/manconfig.h (is_changed, is_directory, escape_shell, remove_directory, trim_spaces, lang_dir, init_locale): Move to ... * lib/util.h: ... here (new file). * lib/Makefile.am (libman_la_SOURCES): Add util.h. * lib/util.c, src/accessdb.c, src/catman.c, src/check_mandirs.c, src/descriptions.c, src/globbing.c, src/globbing_test.c, src/lexgrog.l, src/lexgrog_test.c, src/man-recode.c, src/man.c, src/manconv_main.c, src/mandb.c, src/manp.c, src/manpath.c, src/straycats.c, src/whatis.c, src/zsoelim_main.c: Include util.h.
Diffstat (limited to 'include')
-rw-r--r--include/manconfig.h9
1 files changed, 0 insertions, 9 deletions
diff --git a/include/manconfig.h b/include/manconfig.h
index 0c3fecbf..117a2b0c 100644
--- a/include/manconfig.h
+++ b/include/manconfig.h
@@ -197,15 +197,6 @@ extern void debug_error (const char *message, ...)
struct pipeline;
-/* util.c */
-extern int is_changed (const char *fa, const char *fb);
-extern int is_directory (const char *path);
-extern char *escape_shell (const char *unesc);
-extern int remove_directory (const char *directory, int recurse);
-extern char *trim_spaces (const char *s);
-extern char *lang_dir (const char *filename);
-extern void init_locale (void);
-
NODISCARD extern char *appendstr (char *, ...) ATTRIBUTE_SENTINEL ();
extern int quiet; /* be quiet(er) if 1 */