summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2010-09-27 00:28:41 +0100
committerColin Watson <cjwatson@debian.org>2010-09-27 00:28:41 +0100
commit9eea6f5d590ca001ee29f4806a665b4f1dca54fa (patch)
treecaae0e8141212f0d9e9a91754888fb837133e319 /include
parent4274affde9622e429f2937c569cd76f38722cb0d (diff)
Move security to libman.
* src/security.c: Move to ... * lib/security.c: ... here. * src/security.h: Move to ... * lib/security.h: ... here. * lib/Makefile.am (libman_la_SOURCES): Add security.c and security.h. * src/Makefile.am (lexgrog_SOURCES): Remove fake_security.c and security.h. (man_SOURCES, mandb_SOURCES): Remove security.c and security.h. * lib/README: Add security.*. * src/lexgrog_test.c: Call init_security, so that we can use generic security functions rather than fake_security. * src/fake_security.c: Remove. * lib/security.c (do_system_drop_privs): Unroll calls to do_system into calls to pipeline_start and pipeline_wait. * src/whatis.c (use_grep): Likewise. * src/util.c (do_system): Remove. * include/manconfig.h.in (do_system): Remove. * src/*.c: Update #include grouping for movements to libman.
Diffstat (limited to 'include')
-rw-r--r--include/manconfig.h.in1
1 files changed, 0 insertions, 1 deletions
diff --git a/include/manconfig.h.in b/include/manconfig.h.in
index 3c1c6312..78b5edf2 100644
--- a/include/manconfig.h.in
+++ b/include/manconfig.h.in
@@ -361,7 +361,6 @@ extern int find_name_decompressed (struct pipeline *p, const char *filename,
/* util.c */
extern int is_changed (const char *fa, const char *fb);
extern int is_directory (const char *path);
-extern int do_system (struct pipeline *pl);
extern char *escape_shell (const char *unesc);
extern int remove_directory (const char *directory);
extern char *trim_spaces (const char *s);