summaryrefslogtreecommitdiff
path: root/init
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2019-01-05 10:02:17 +0000
committerColin Watson <cjwatson@debian.org>2019-01-05 10:02:17 +0000
commitd6e1c04c7f2592f8aeaf2b1a00d894992790e8a1 (patch)
treecf2cb0db11e700f07dd0297ac3ed7a6b8ef66cf4 /init
parent97591079ee87b6f72fd57ba393dbd1a29d4d84f5 (diff)
Fix distribution of man-db.timer
Automake's "_DATA" primary defaults to "nodist_", not "dist_". * init/systemd/Makefile.am (systemdsystemunit_DATA): Rename to ... (dist_systemdsystemunit_DATA): ... this. (nodist_systemdsystemunit_DATA): Rename to ... (systemdsystemunit_DATA): ... this. (EXTRA_DIST): Add man-db.timer if INSTALL_SYSTEMD_TIMER is false.
Diffstat (limited to 'init')
-rw-r--r--init/systemd/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/init/systemd/Makefile.am b/init/systemd/Makefile.am
index 94df2c10..ecbac43b 100644
--- a/init/systemd/Makefile.am
+++ b/init/systemd/Makefile.am
@@ -27,18 +27,20 @@ CLEANFILES = \
man-db.service
if INSTALL_SYSTEMD_TMPFILES
-nodist_systemdtmpfiles_DATA = man-db.conf
+systemdtmpfiles_DATA = man-db.conf
man-db.conf: man-db.conf.in
sed -e "s,[@]cache_top_owner[@],$(cache_top_owner),g" $< > $@
endif
if INSTALL_SYSTEMD_TIMER
-systemdsystemunit_DATA = man-db.timer
-nodist_systemdsystemunit_DATA = man-db.service
+dist_systemdsystemunit_DATA = man-db.timer
+systemdsystemunit_DATA = man-db.service
man-db.service: man-db.service.in
sed -e "s,[@]bindir[@],$(bindir),g" \
-e "s,[@]cache_top_owner[@],$(cache_top_owner),g" \
$< > $@
+else
+EXTRA_DIST += man-db.timer
endif