summaryrefslogtreecommitdiff
path: root/lib/cleanup.c
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2007-12-13 11:39:01 +0000
committerColin Watson <cjwatson@debian.org>2007-12-13 11:39:01 +0000
commit4ff30791b6fe2c2a13c1d5a77a17013e7a931317 (patch)
treef81b3feb6693085faae8ea277a985355441411b2 /lib/cleanup.c
parent7fcab0fcb1622b4c8e7c54d32d5555bfd673676f (diff)
* configure.ac (AM_GNU_GETTEXT_VERSION): Upgrade to gettext 0.17.
* gnulib: Upgrade to Debian 20071201+dfsg-1. * README (Copyright and licensing): New section. Explain the implications of Gnulib components being distributed under GPL v3. * .bzrignore: Ignore gnulib/lib/fcntl.h.
Diffstat (limited to 'lib/cleanup.c')
-rw-r--r--lib/cleanup.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/cleanup.c b/lib/cleanup.c
index 47faa49f..c0e68a43 100644
--- a/lib/cleanup.c
+++ b/lib/cleanup.c
@@ -206,9 +206,9 @@ push_cleanup (cleanup_fun fun, void *arg, int sigsafe)
slot *new_stack;
if (stack) {
- new_stack = xrealloc (stack, (nslots+1)*sizeof(slot));
+ new_stack = xnrealloc (stack, nslots+1, sizeof (slot));
} else {
- new_stack = xmalloc ((nslots+1)*sizeof(slot));
+ new_stack = xnmalloc (nslots+1, sizeof (slot));
}
if (!new_stack) return -1;