summaryrefslogtreecommitdiff
path: root/lib
diff options
context:
space:
mode:
authorColin Watson <cjwatson@debian.org>2022-02-10 12:32:53 +0000
committerColin Watson <cjwatson@debian.org>2022-02-10 12:32:53 +0000
commit8729cc9a129888d81024f59510ac45a464a032c5 (patch)
treef720dee930393e24ee296c443b675ffaa77e0cbd /lib
parent828b489c68a5a022c106656cfdff19bb9b584eec (diff)
parent2e5ffdc7d1805c855ddb61527ba665bac171b18e (diff)
Import man-db_2.10.1.orig.tar.xz
Diffstat (limited to 'lib')
-rw-r--r--lib/Makefile.am1
-rw-r--r--lib/Makefile.in2
-rw-r--r--lib/cleanup.c2
-rw-r--r--lib/encodings.c3
-rw-r--r--lib/security.c2
-rw-r--r--lib/util.c1
6 files changed, 5 insertions, 6 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 475fea04..49f7809f 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -70,4 +70,5 @@ libman_la_LIBADD = ../gl/lib/libgnu.la $(LTLIBOBJS) \
libman_la_LDFLAGS = \
-avoid-version -release $(VERSION) -rpath $(pkglibdir) \
-no-undefined \
+ $(LIBMAN_EXPORT_LDFLAGS) \
$(libseccomp_LIBS)
diff --git a/lib/Makefile.in b/lib/Makefile.in
index 3aa38d11..72753697 100644
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -1144,6 +1144,7 @@ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
LIBCOMPRESS = @LIBCOMPRESS@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
+LIBMAN_EXPORT_LDFLAGS = @LIBMAN_EXPORT_LDFLAGS@
LIBMULTITHREAD = @LIBMULTITHREAD@
LIBOBJS = @LIBOBJS@
LIBPMULTITHREAD = @LIBPMULTITHREAD@
@@ -1687,6 +1688,7 @@ libman_la_LIBADD = ../gl/lib/libgnu.la $(LTLIBOBJS) \
libman_la_LDFLAGS = \
-avoid-version -release $(VERSION) -rpath $(pkglibdir) \
-no-undefined \
+ $(LIBMAN_EXPORT_LDFLAGS) \
$(libseccomp_LIBS)
all: all-am
diff --git a/lib/cleanup.c b/lib/cleanup.c
index 6c7c18ae..b122de82 100644
--- a/lib/cleanup.c
+++ b/lib/cleanup.c
@@ -75,7 +75,7 @@ sighandler (int signo)
/* signal has now default action and is unmasked,
reraise it to terminate program abnormally */
- kill (getpid(), signo);
+ raise (signo);
abort();
}
diff --git a/lib/encodings.c b/lib/encodings.c
index 0db5b8c0..1f8dae10 100644
--- a/lib/encodings.c
+++ b/lib/encodings.c
@@ -26,6 +26,7 @@
#endif /* HAVE_CONFIG_H */
#include <stdbool.h>
+#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <unistd.h>
@@ -40,8 +41,6 @@
#include "manconfig.h"
-#include "pipeline.h"
-
#include "debug.h"
#include "encodings.h"
#include "pathsearch.h"
diff --git a/lib/security.c b/lib/security.c
index 676e6d79..ab17da91 100644
--- a/lib/security.c
+++ b/lib/security.c
@@ -42,8 +42,6 @@
#include "manconfig.h"
-#include "pipeline.h"
-
#include "cleanup.h"
#include "debug.h"
#include "fatal.h"
diff --git a/lib/util.c b/lib/util.c
index 88ff28ad..c9c16d1b 100644
--- a/lib/util.c
+++ b/lib/util.c
@@ -58,7 +58,6 @@
#include "debug.h"
#include "error.h"
-#include "pipeline.h"
#include "util.h"
/*